1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

.Package psa-spamassassin needs perl(Mail::SpamAssassin::NoMailAudit), this is not av

Discussion in 'Plesk for Linux - 8.x and Older' started by Gorgon@, Jan 3, 2006.

  1. Gorgon@

    Gorgon@ Guest

    0
     
    Hi folks,

    I know this issue has been asked before and I've read up on it but in those cases, people seemed to be trying run spamassassin v3 w/ PSA. Here is my situation.

    I had to do a complete rebuild of a RHES3 system recently. This server is still running PSA v7.5.3. An upgrade is not planned until this weekend at the earliest.

    I setup automatic yum updates using the RH servers and DAG. I'm not using atomicturtle (at least on this server yet). Now each night when yum tries to update we get this error:

    .Package psa-spamassassin needs perl(Mail::SpamAssassin::NoMailAudit), this is not available.

    Here are the versions of spamassassin and psa-spamassassin:

    spamassassin-2.63-0.2
    psa-spamassassin-7.5.3-rhel3.build75050506.13

    I thought maybe PSA didn't like that version of SA so I grabbed SA v2.55 from RH. But apparently psa-SA requires SA v2.60 or better.

    So I'm confused. Everything seems to be the right version yet yum says a dependency is missing. Any thoughts?

    Thanks,
    mikeS
     
  2. Who-m3

    Who-m3 Guest

    0
     
    This package, in RPM form, should be included in the opt/mail directory of your installation. It is a perl module, it's simple to install (rpm -Uvh ...).
     
  3. jshanley

    jshanley Guest

    0
     
    Argh.

    AFAIK, Plesk uses 2.6.1 or 2.6.2. Yes, the one from December 2003. I wonder if SW-Soft even realizes that SpamAssassin 3.0 was released in September 2004 (over a year ago), and you can't even download a version before 3.0 anymore from their site?

    The current version is 3.10. I wonder if they'll upgrade to 3.0 by the time SpamAssassin 4.0 is out.
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
  5. jshanley

    jshanley Guest

    0
     
    This is true on LInux, because of the structure SW-Soft uses for the linux versions of Plesk. The FreeBSD version, however, is significantly harder to convert because everything is "bundled" into the Plesk package.
     
  6. Gorgon@

    Gorgon@ Guest

    0
     
    Thanks for all your advice folks. I forced SA v2.63 to be installed again but that didn't help. I think it has something to do with the fact that I only had DAG setup in yum at the moment.

    I think I'll wait until I upgrade to v7.5.4 and see what happens. I have a suspicion that will help things out. :)

    I'm going to build out my next server using the ART stuff and get my feet wet with that first and then I'll look into 'upgrading' my current server using the same methods. That'll get us SA v3.x. :)

    thanks again,
    M
     
Loading...