1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Perl LWP Module

Discussion in 'Plesk for Linux - 8.x and Older' started by sretlaw, Apr 11, 2007.

  1. sretlaw

    sretlaw Guest

    0
     
    I am having problems getting the PERL LWP modules (Simple and UserAgent) working with Plesk 8.1 when the url I am trying to grab is on the Plesk server. Basically, I'm trying to grab the output from a PERL script on one name-based domain on the server, to use in a PERL script at a second name-based domain on the same server. This worked in previous versions of Plesk.

    The LWP modules work fine when the url I'm trying to grab is on a different server.

    The LWP modules also seem to work when I use IP-based hosting in Plesk, but this causes me some other problems, so I'd rather not do that.

    I'm not sure if this a firewall issue (and how/if it can be fixed) or if it is another configuration problem.

    Thanks for your help.
     
  2. sretlaw

    sretlaw Guest

    0
     
    LWP Problem Solved

    Figured it out...

    1. Must use full url, including "www" prefix

    2. Can't grab a page that is being redirected

    For some reason, both of these conditions worked in Plesk 7.
     
Loading...