• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Permission denied, can't remove subdomain

tomer628

Basic Pleskian
i got this error anytime i want remove subdomain of seficific domain
for example:
i have 2 domains example.com andexmaple2.com.
and if i create subdomain for domain exapmle.com, and after that i delete subdomain, it delete without problems.
BUT if create subdomain for exapmle2.com, and after that i delete subdomain, this NOT deleted - igot this error Error: Permission denied to remove subdomain ID 14.
(i just remember that i change the password of admin)

someone told me there is mabe virus onexapmle2.com or maybe this domain hacked and this what gave me the error...

1. how can i fix that ?

2. how can I know if my domain hacked?

regards,
Tomer.
 
Hi tomer628,
what about if you delete the subdomain via command line?
Code:
# plesk bin site -r subdomain.example2.com


And I'd make sure all the permissions are ok on example2.com...
Code:
# plesk repair fs example2.com

I hope that helps
Kind regards

Lloyd
 
from command line with
Code:
# plesk bin site -r subdomain.example2.com
it's delete, but from the web it's not..
also i checked the repair command..
and i got this result:
Code:
Checking virtual hosts' file system ................................. [OK]

Error messages: 0; Warnings: 0; Errors resolved: 0
 
Back
Top