1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice
  1. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    Build is 10.4.4 Windows 2003/2008 20111103.18 on Windows 2008 64 bit and is up to date. (Update #27)

    Faulting application php-cgi.exe, version 5.3.10.0, time stamp 0x4f2ae509, faulting module php5ts.dll, version 5.3.10.0, time stamp 0x4f2ae5d1, exception code 0xc0000005, fault offset 0x000a37c6, process id 0xf5c, application start time 0x01cd271715378ec2.

    It is from updating all RSS imports in IPB software as of 3.3.1 run by you that set my server up.

    What could be causing this? I did try to check with IPB as of http://www.invisionpower.com first as they stated

    I said in reply that I understand that you cannot figure it out and later on I'm going to contact Parallels Support Team to get this fixed.

    So what should I do or waste 75 for to just submit a ticket to get it fixed?
     
    Last edited: Apr 30, 2012
  2. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    just a update as manually to upgrade PHP to 5.3.11 from plesk's php of 5.3.10 seems to work now as it was and now there is a timeout issue.

    The real error with PHP 5.3.11 is "C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP53\php-cgi.exe - The FastCGI process exceeded configured activity timeout" I wonder what is timing it out.
     
  3. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    After more research being done I find a Configuration Sample

    The following configuration sample adds a FastCGI application for PHP, sets the instanceMaxRequests attribute to "10000," and sets the PHP_FCGI_MAX_REQUESTS environment variable to "10000."
    <fastCgi>
    <application fullPath="C:\PHP\php-cgi.exe"
    arguments=""
    maxInstances="4"
    idleTimeout="300"
    activityTimeout="30"
    requestTimeout="90"
    instanceMaxRequests="10000"
    protocol="NamedPipe"
    flushNamedPipe="false">
    <environmentVariables>
    <environmentVariable
    name="PHP_FCGI_MAX_REQUESTS"
    value="10000" />
    </environmentVariables>
    </application>
    </fastCgi>

    I wonder where that file is or to create it as activityTimeout could be the field that is timing it out.
     
  4. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    Also a better understanding...

    HTTP Error 500.0 - Internal Server Error

    C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP53\php-cgi.exe - The FastCGI process exceeded configured activity timeout


    this is the real error and do you have a clue why this is happening? even I did a check manually as you look below.

    C:\>cd Windows\System32\inetsrv
    C:\Windows\System32\inetsrv>appcmd list config -section:system.webServer/fastCgi
    <system.webServer>
    <fastCgi>
    <application fullPath="C:\Program Files (x86)\Parallels\Plesk\Additional\Ple
    skPHP5\php-cgi.exe">
    <environmentVariables>
    </environmentVariables>
    </application>
    <application fullPath="C:\Program Files (x86)\Parallels\Plesk\admin\bin\php-
    cgi.exe" maxInstances="12" idleTimeout="1800" activityTimeout="3600">
    <environmentVariables>
    </environmentVariables>
    </application>
    <application fullPath="C:\Program Files (x86)\Parallels\Plesk\Additional\PHP
    \php.exe">
    <environmentVariables>
    </environmentVariables>
    </application>
    <application fullPath="C:\Program Files (x86)\Parallels\Plesk\Additional\Ple
    skPHP53\php-cgi.exe">
    <environmentVariables>
    </environmentVariables>
    </application>
    </fastCgi>
    </system.webServer>
    C:\Windows\System32\inetsrv>
     
  5. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    However it seems that was a fake error because I have activitytimeout increased manually already. I need to know how to increase it in plesk control panel in domain's hosting setting though.
     
    Last edited: May 2, 2012
Loading...