1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PLESK 10.4.4 PHP settings not saved

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by IgoKonrads, Dec 8, 2011.

  1. IgoKonrads

    IgoKonrads Guest

    0
     
    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    PLESK, 10.4.4, CENTOS 5.7, 64x

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    After upgrading from 10.3.1 to 10.4.4 Many domains showing errors related to PHP safe mode restrictions. I checked the PHP.ini file and indeed for some reason safe mode is turned ON. I then tried to change the settings for the subscription these domains use, but after setting php safe_mode to "off" and saving the changes and logging back in, it's set to default again. In other words php settings are ignored. Tried this also for the actual domain rather than the subscription they are using - same problem.

    ACTUAL RESULT
    PHP settings not saved under subscriptions and domains

    EXPECTED RESULT
    PHP setting changes to take effect after saving them.

    ANY ADDITIONAL INFORMATION
    Thanks..

    --------------------------------------------------------------
     
  2. mkoninkx

    mkoninkx New Pleskian

    22
    23%
    Joined:
    Feb 4, 2009
    Messages:
    9
    Likes Received:
    0
    Count 2: Same problem here... Plesk 10.4.4 MU6 on Debian 5 x64
     
  3. Raf007

    Raf007 Guest

    0
     
  4. Mshaker

    Mshaker Basic Pleskian

    18
    85%
    Joined:
    Oct 21, 2010
    Messages:
    75
    Likes Received:
    0
    Same problem

    He have the exact same problem on centos 5.7 x64. Having the plesk 10.4.4 control panel broken every other week is getting boring.
     
  5. Ihno1

    Ihno1 New Pleskian

    16
    35%
    Joined:
    Jan 24, 2011
    Messages:
    22
    Likes Received:
    0
    ...same problem here on Plesk 10.4.4 MU7 with debian lenny x32 & x64 machines
     
  6. Thufir

    Thufir Guest

    0
     
    I came across a similar problem in the past, with Plesk 7.<something> then again in later versions.

    Here's what I've personally seen, it may help you out.
    -------------------------------------------------
    I believe this must be done as server admin, not the domain admin.

    In Plesk 10.4.4, for each domain showing the problem, go to subscription, then click the domain name. From there click the "Customize" button, then the tab for "PHP Settings".

    In the second section, "Common Settings" there is an option for safe_mode. If this is set to Yes, it will override the php.ini settings for that specific domain.

    This may be reset or default due to an upgrade/update, I'm not sure.
    -------------------------------------------------

    This may not be your solution, but it's helped me in the past, so hopefully it will get you working again.
     
    Last edited by a moderator: Dec 16, 2011
  7. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    I have the same problem since Plesk 10.4.4. I use Debian Lenny 5 x64.

    Not only the settings are not saved - my old setting, safe_mode = off, is overwritten!

    I need a patch for this very quickly.
     
    Last edited: Dec 16, 2011
  8. mandi22

    mandi22 Guest

    0
     
    Same problem Plesk 10.4.4 Debian
     
  9. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    Now I set safe_mode = Off for ALL domains directly via the php.ini in the apache folder. I hope Plesk will shortly allow us to set it per domain, because only some of my domains need safe_mode = Off (and "Off" for every domain seems too unsecure to me).
     
  10. fidget253

    fidget253 New Pleskian

    12
    60%
    Joined:
    Dec 21, 2011
    Messages:
    3
    Likes Received:
    0
    Same issue

    Im having a similar issue. I can't set upload size while running fastcgi in /var/www/vhosts/example.com/etc. issue was not happening on 10.4.4 before MU 5
     
  11. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,539
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    Use the workaround of settings safe_mode=off in the global system php.ini
     
  12. nevakee

    nevakee Basic Pleskian

    19
    60%
    Joined:
    Dec 12, 2010
    Messages:
    61
    Likes Received:
    0
    I have the same problem.
    All PHP settings are not saved in the php.ini file, but only for customers who after Nov 29, 2011 were created.
    Same reseller, same service plans

    E.g.
    Plesk: display_errors = off
    customers php.ini: display_errors = on
    etc...

    Parallels Plesk Panel v10.4.4_build1013111102.18 os_Debian 6.0
    10.4.4 Update #9
     
    Last edited: Dec 24, 2011
  13. AurelienG

    AurelienG Guest

    0
     
    Same problem Plesk 10.4.4 Ubuntu

    I try to apply the safe_mode = off on every hosting package but no change
     
  14. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,539
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
  15. GlobalServe

    GlobalServe Basic Pleskian

    24
    23%
    Joined:
    Aug 15, 2005
    Messages:
    89
    Likes Received:
    0
    OK for the work arround, but is this going to be fixed?
    What is the use now for an own custom php file / domain?
     
  16. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,539
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    BTW, as far as I remember, safe_mode = off in /etc/php.ini is one of requirements before Plesk installation.
     
  17. AurelienG

    AurelienG Guest

    0
     
    Hello,
    or is global php.ini?
    I do not see : /etc/php.ini
    And how to change the local_value ?
     
    Last edited by a moderator: Dec 27, 2011
  18. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,539
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    On my test Plesk environment I see:

     
  19. AurelienG

    AurelienG Guest

    0
     
    My file php.ini in ubuntu plesk:
    but I can not find a php.ini for each domain
    if I search all files php.ini on my system
     
    Last edited by a moderator: Dec 28, 2011
  20. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    There are no php.ini files per domain. Only the global ones. And you have to edit the global php.ini.
     
Loading...