1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 11 Install Fails: Zend_Exception: File "Db\Adapter\Pdo\Mysql.php" does not exis

Discussion in 'Plesk 11.x for Windows' started by MitchellK, Nov 9, 2012.

  1. MitchellK

    MitchellK New Pleskian

    19
    35%
    Joined:
    Aug 27, 2009
    Messages:
    6
    Likes Received:
    0
    I am trying to install Plesk 11 on a fresh Windows 2008 SP2 64bit server. After I run the autoinstaller (AI.EXE) and I try to open the Plesk interface in a browser, I receive the following error message:

    During installation, I noticed several warnings in the console that "The system cannot find the file specified."

    I have tried to uninstall and reinstall Plesk, but the same thing happens again. I have had the same problem on two different servers. What is the problem here?
     
  2. MitchellK

    MitchellK New Pleskian

    19
    35%
    Joined:
    Aug 27, 2009
    Messages:
    6
    Likes Received:
    0
    As an addendum to my previous post, it looks like the culprit for this problem is that Plesk did not install the scripts needed in the admin/plib/Db/Adapter/Pdo directory. Seems that there should be a file called Mysql.php in here, and there is none.
     
  3. jbcampos

    jbcampos New Pleskian

    11
     
    Joined:
    Nov 8, 2012
    Messages:
    20
    Likes Received:
    0
    Havn't run into this problem with plesk 11 I just did a base install on a windows 2012 server without any roles or anything installed on it yet. The installer should be self contained. Maybe the installer is hosed? Or its possible when it extracted the files something got screwed up? I'd try just downloading it again or wiping the extracted files out and run ai.exe again.

    I know that's not much but figured i'd throw in my two cents since plesk 11 forum posts seem to be fairly quiet in responses.
     
  4. MitchellK

    MitchellK New Pleskian

    19
    35%
    Joined:
    Aug 27, 2009
    Messages:
    6
    Likes Received:
    0
    Well, I reuninstalled (?) Plesk, and then removed the /Program Files (x86)/Parallels/Plesk/admin folder as well as the /Plesk/admin folder. After that, I redownloaded the autoinstaller, and installed it again. This time it worked. Strange. Perhaps there was an issue when attempting to download the mysql.php file. Thanks for your help.
     
Loading...