• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Plesk 12.5 Broken MySQL after Update

Scott_Cameron

New Pleskian
Hello!

Basically.. Using updates and upgrades tool in Plesk I updated the MySQL as a new update was available. While doing so it appears the update had crashed or the update never went fully through however what did happen was remove MySQL as it was. Now when you try to connect to the admin or any client sites, you're presented with a MySQL connection error.

Here is the error when connecting to the panel
Code:
ERROR: PleskDBException: Unable to connect to database: mysql_connect(): Resource temporarily unavailable /var/run/mysqld/mysqld.sock (Error code: 2002). Please check that database server is started and accessible. (Abstract.php:69)

We're using Debian 8 & Plesk 12.5.

Any ideas of how to resolve this? I've attempted to use the repair tool but they present almost the same error.
 
If you can't repair your MySql server by yourself with help of OS package manager, I'd suggest you contact Plesk Support Team.
 
Back
Top