1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 7.5.4 > 8.0.1 backup/restore

Discussion in 'Plesk for Linux - 8.x and Older' started by gerhard@, Oct 17, 2006.

  1. gerhard@

    gerhard@ Guest

    0
     
    I have Plesk 7.5.4 running on RH9 and have switched to Plesk 8.0.1 on CentOS 4.4. I backed up one of my domains using this utility http://download1.swsoft.com/Plesk/Plesk8.0/Extensions/bu/backup-agent-8.0.1.html and everything worked fine. When I try creating a map file in order to edit it (IPs have changed, dir structure etc.), this is the output in the map file:
    PHP:
    []          # Client account does not exist.

    domain.com x.x.x.x          # ip address has improper value x.x.x.x
    .

    I am running the following command to create the map file:
    PHP:
    /usr/local/psa/bin/pleskrestore --create-map domain_backup -map domain_map
    .

    Restoring Plesk 7.5.4 websites into 8.0.1 is SUCH a pain!!! Any other way around it (I can't upgrade, it's RH9).
     
  2. sieb@

    sieb@ Guest

    0
     
    The Migration Manager worked surprisingly well for me. I couldn't get my dumps to restore into 8.0.1, it wouldn't read them.
     
  3. gerhard@

    gerhard@ Guest

    0
     
    Yes, Migration Manager seems to be working really good for me too. Cheers for that ;), Gerhard.
     
  4. justman

    justman Guest

    0
     
    more details on how to restore a www of 7.5 to an 8.0 plz

    sorry everyone,
    i must ask a dumb question...
    could anyone shed lights on how to restore a domain backup of plesk 7.5 to current plesk 8.0?? it is a redhat here.
    or at least extract the web part out of plesk7.5 backup.

    thanx
    justman
     
  5. gerhard@

    gerhard@ Guest

    0
     
    Justman, use the Migration Manager on the server you are restoring TO (NOT from).

    You must have SSH access on the server you are restoring FROM (make sure root login is enabled by default - root@your.domain.com) and that you specify the right port (22 by default, 8888 or anything else on hardened boxes).

    You can restore the whole server like that, but I would recommend restoring domains 1 by 1, creating clients and assigning the restored domains manually. If you want to keep the same structure as on the old server, just restore it all (please find this option @ step 3 - I think - when restoring through Migration Manager).

    Please refer to Plesk 8 Admin Manual for more details on Migration Manager.
     
  6. justman

    justman Guest

    0
     
    thanx gerhard,

    let me describe my situation more closely. i have a plesk7.5 backup file on the redhat server, which just got upgraded to plesk 8.0

    the backup file should contain only one domain, but i can't be 100% sure. after playing with this file and gunziping it, i think it is in xml format. but, i don't know how to extract the website folder (/httpdocs) from it...

    i will keep trying to learn 'migration manager' as you mentioned. but, i haven't gotten any success...

    thanx again :)
     
  7. justman

    justman Guest

    0
     
    hm...

    the migration manager is disgned to move data from other 'running' application, but from a backup...

    the funny thing is that i finnally understand what does the first level post means. i try to restore a plesk8 backup by using

    ./pleskrestore

    the exact same error comes up...
    could any one give me some ptr to answer?? some forum?? hum???
     
  8. dw604

    dw604 Guest

    0
     
    Uninstall 8.0 and reinstall 7.5.4 and key, restore backup, then upgrade if you want.

    Regards
     
  9. justman

    justman Guest

    0
     
    thanx dw604,

    but i dont have plesk software at all...
    our server host vendor has gone from plesk7.5 to plesk8.0

    just to share experiences of using ./pleskrestore,
    even for a backup file generated by plesk8.0, when you do a commandline restore, at the step
    ./pleskrestore --restore 'backup' -map 'backup_map' -level all
    , it generates the same error as posted in 1st floor...
     
  10. gerhard@

    gerhard@ Guest

    0
     
    Hi justman, you are saying that you have back-ups from which you want to restore the actual domains/clients. Is there any chance for you to use Migration Manager to bring data&settings across?

    The error that I was getting was due to the fact that IPs on the box I'm hosting have also changed. Now then, I see no reason for your host to change the IPs of your original machine. This hints that you might have been moved onto another server/VPS. Ask your host to allow you to restore your back-ups temporarily on a 7.5.4 install and then use Migration Manager to bring them into your Plesk 8 box.

    I don't know if this is the best way really, but it's the only tried & tested one I know of. Plesk restores & back-ups were always fiddly little things with a high chance of something, somewhere going wrong. See what your host recommends or, even better, SW-Soft folks.
     
  11. dw604

    dw604 Guest

    0
     
    Plesk can be downloaded free from the plesk.com "Download" section but you must register and login.

    If you are on Fedora Core 4 or higher (cat /etc/*rele*) grab 8.0 autoinstaller for your Linux distribution. (if lower, grab 7.5.4 autoinstaller for your release) Make it executable, delete the 'psa' mysql database... (mysql -u admin -p) then (drop database psa) from within MySQL utility. This is important to avoid a plesk database version error on installation.

    Run this command to remove all old Plesk RPMs:

    for file in `rpm -qa | grep psa`; do rpm -e --nodeps $file; done;

    Run the 8.0 autoinstaller and choose 7.5.4 as the install version. Choose your options and it will install. After that you may have to set up your server IPs in the default 7.5.4 install and then you can restore your backup which includes, I think, the old plesk key.

    UPDATE: Sorry, I haven't used migration manager or pleskrestore. I use

    psadump -F --do-not-dump-logs -f my.dump

    ...for backup, and:

    psarestore -f my.dump -m ip_file -s shells_file

    This will create the ip_file file which you need to edit...

    Near the bottom where you see

    12.34.56.78 -> # 255.255.255.255

    Add your target IP like so, even if it's the same:

    12.34.56.78 -> 12.34.56.78 # 255.255.255.255

    Then run the restore command again:

    psarestore -f my.dump -m ip_file -s shells_file
     
  12. justman

    justman Guest

    0
     
    the plesk7.5 backup only contains one domain and all that matters is the website.

    from plesk8.0 migration manager, i try to see whether i can make the content of plesk7.5 backup show up, but i don't think there is a way.

    i don't have another plesk... all i have is the current plesk8.0 running on redhat and a plesk7.5 backup
    plus, ssh and ftp is my only way to get to the redhat.

    about the error message, I KNOW!! the ip address is same, and let me stress that fact that it IS a plesk8.0 backup! this plesk8.0 backup was generated through plesk8.0 gui in order for me to see through a commandline restore procedure. but, surprisingly, the same error ip message showed up!! (i can still restore with this backup using plesk8.0 gui, so it is a valid backup...)

    anyway, i am stuck until ev1 throws me some bones...

    thanx 4 the suggestion :)
     
  13. justman

    justman Guest

    0
     
    :) dw604

    i didn't know i can download it 4 free!!
    your instructions for procedures on fedora sounds so tempting....
    i will give it a shot on our redhat.

    ...wouldn't you happen to know whether it works on redhat, would you?
    since i would be modify part of plesk8.0 (it looks so to me), the last thing i want is to break the system...

    any suggestion? pointer??
     
  14. dw604

    dw604 Guest

    0
     
    There is a version for most systems... yes. If you 'break' the system you should be able to start from scratch by using the 'remove rpms' command-line i provided and then using the autoinstaller (download from plesk.com) to reinstall whatever version you want.
     
  15. justman

    justman Guest

    0
     
    thank you so much :))

    i think i will have a fun day tomorrow :)
     
  16. willlangford

    willlangford Guest

    0
     
    i tried this on my new centos install

    foreach file in `rpm -qa | grep psa`; do rpm -e --nodeps $file; done;

    and i got this error

    [root@badass home]# foreach file in `rpm -qa | grep psa`; do rpm -e --nodeps $file; done;
    -bash: syntax error near unexpected token `do'

    anyone have any ideas?!
     
  17. dw604

    dw604 Guest

    0
     
    Sorry, change foreach to just for...
     
  18. willlangford

    willlangford Guest

    0
     
    thx worked great! now i have dns issues...i made a new thread.
     
Loading...