1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 7.5.4 and PHP5 (again)

Discussion in 'Plesk for Linux - 8.x and Older' started by rjbrooksjr, Mar 9, 2006.

  1. rjbrooksjr

    rjbrooksjr Guest

    0
     
    It seems these questions have been beaten to death, but I can't really achieve an official answer here.

    I have a dedicated server though 1and1. It has Plesk 7.5.4, and fedora2. I REALLY want to switch to PHP5 very badly. Is this feesable? I saw the knoweldgebase article saying yes you can, but I also see posts saying don't do it... it breaks horde... etc. This would be a fairly high risk upgrade for me to do, so I'm trying to be sure I know EXACTLY what I'm doing here.

    Is there a set of steps laid out now that I can go through with a fair level of success?

    Thank you.
     
  2. Highland

    Highland Guest

    0
     
  3. rjbrooksjr

    rjbrooksjr Guest

    0
     
    so in theory, i can yum those rpm's, and nothing should break?
     
  4. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
  5. vangok

    vangok Guest

    0
     
    some dummy question, how to install that rpm. I have standart repo list from your site, i put one more chanal in it:
    [atomic unstable]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA-Compatible RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic-bleeding/art/$releasever/

    acctually it have to be everything ok, but after

    yum install php

    I got installing of php4.4 not php5.

    What i am doing wrong?
     
  6. sybersnake

    sybersnake Guest

    0
     
    what about those of us who are on Virtual Private servers? I got a virtual private service because i was told by a tech that i should be able to install php5 on it. My service seems to be fedora core 2 and does not have yum installed.

    I've been looking through all the directories as root@ been trying to find the apache/php files for the user sites.
     
  7. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    What Distro are you on? I've only got PHP 5.1 packages available for FC2/FC3/FC4 and 4ES. I probably wont be able to do packages for RH9 or 3ES without making some major changes to the OS.

    second question, for VPS users, you need to get an updater on your system, like yum or up2date. I'd ask your hoster how they are updating the system, and if they have a specific reason why they didnt include it. They may have a really good one, like they are maintaing your packages for you, and using yum could cause the 2 to get out of sync.
     
  8. sybersnake

    sybersnake Guest

    0
     
    i get this message

    Error: Missing Dependency: libpq.so.3 is needed by package php-pgsql
    Error: Missing Dependency: libmysqlclient.so.14 is needed by package php-mysql
    Error: Missing Dependency: php-domxml is needed by package psa-horde

    when trying todo 'yum update'

    using

    [psa-7.5]
    name=Atomic Rocket Turtle - $releasever - SW-Soft PSA 7.5 RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic/psa-7.5/$releasever/

    # THIS CHANNEL CONTAINS MY PSA COMPATIBLE RPMS (php, mysql, qmail-scanner, etc)
    [atomic-bleeding]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA-Compatible RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic-bleeding/art/$releasever/

    [atomic-app-vault]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA App Vault RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic/app-vault/
     
  9. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    You'll need the atomic, base and updates channels too. Thats linked against mysql 4.1, and the other dependencies are core to the OS.
     
  10. vangok

    vangok Guest

    0
     
    what does it mean?

    Resolving dependencies
    ........Unable to satisfy dependencies
    Package php-domxml needs php = 4.3.11-1.fc2.4.legacy, this is not available.
     
  11. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    You need to remove php-domxml, and maybe even all of php4 before trying to install php5 or 5.1. Its absolutely not a "clean" upgrade path, since the architecture has changed so much.
     
  12. vangok

    vangok Guest

    0
     
    well, I've done everything...
    Plesk still works :)
    but apache not and I cannot start webserver service

    Service is not available now, probably your Plesk is misconfigured.
    Contact Your provider for details.

    Internal Plesk error occurred: Unable to make action: Unable to manage service by websrvmng: websrvmng: Service httpd failed to start

    some advise?
     
  13. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    If you have any debugging info you can send me that'd be great, just keep in mind that the atomic-unstable channel is about as raw and untested as it gets. I haven't even run any of those packages yet.
     
  14. vangok

    vangok Guest

    0
     
    :) i see...well try it together...
    i've found folowing logs:

    Mar 14 00:03:20 httpd: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: cannot open shared object file: No such file or directory
    Mar 14 00:03:20 httpd: httpd startup failed

    it still try to load libphp4 and not 5
    some configuration problem...

    I am using fc2, apache2


    Well just changed first line in
    /etc/http/conf.d/php.conf to

    LoadModule php5_module modules/libphp5.so

    now it works some how need to test
     
  15. vangok

    vangok Guest

    0
     
    There is one more thing, my webmail doesnot work after upgrade.
    webmail.domaint.tld show only default plesk page..
    Horde said: "good bay"

    any suggestion?
     
  16. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Yeah you definitely want to remove all of php4 before you try installing php5 or 5.1.
     
  17. vangok

    vangok Guest

    0
     
    well I try to connect via pop3/imap client...the error was that host doesnot in ACL...

    could it be problem of mysql for example and not of php?

    I upgradet mysql to 4.1 too. On ather server that was upgradet mysql work's
    but on that server with php5 not really...



    MORE :) It's very nice, with modules was installed befor upgrade, and i think it's aboit this xmldom lib

    psa-horde Component was not installed
    psa-imp Component was not installed
    drweb Component was not installed
    drweb-qmail Component was not installed
     
  18. sybersnake

    sybersnake Guest

    0
     
    i did "yum remove php.i386'

    and it wanted to remove all of this

    Transaction Listing:
    Remove: php.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: Mambo.noarch 0:4.5.2-7505
    Remove: SSHTerm.noarch 0:0.2.2-fc2.build75050824.12
    Remove: cs-gs.i586 0:1.2.3-fc2.build75050902.17
    Remove: osCommerce.noarch 0:2.2ms2-7509
    Remove: php-devel.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-domxml.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-imap.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-ldap.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-mbstring.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-mysql.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-odbc.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-pear.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-pgsql.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-snmp.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: php-xmlrpc.i386 0:4.3.11-1.fc2.3.legacy.1.swsoft
    Remove: psa.i586 0:7.5.4-fc2.build75050824.12
    Remove: psa-agent.noarch 0:1.3.5-75050930.11
    Remove: psa-api-cli.noarch 0:7.5.4-fc2.build75051014.16
    Remove: psa-api-common.noarch 0:7.5.4-fc2.build75051014.16
    Remove: psa-api-rpc.noarch 0:7.5.4-fc2.build75050930.11
    Remove: psa-bf1942.i586 0:1.0.0-fc2.build75050824.12
    Remove: psa-bu.i586 0:7.5.4-fc2.build75050926.17
    Remove: psa-fileserver.i586 0:1.0.0-fc2.build75050824.12
    Remove: psa-firewall.i586 0:1.0.1-fc2.build75050824.12
    Remove: psa-horde.noarch 0:3.0.5-fc2.build75050824.12
    Remove: psa-hotfix5.i586 0:7.5.4-fc2.build75060118.18
    Remove: psa-imp.noarch 0:4.0.3-fc2.build75050824.12
    Remove: psa-ingo.noarch 0:1.0.1-fc2.build75050824.12
    Remove: psa-kronolith.noarch 0:2.0.3-fc2.build75050824.12
    Remove: psa-manual-custom-skin-guide.noarch 0:7.5.4-fc2.build75050824.12
    Remove: psa-migration-manager.i586 0:7.5.4-fc2.build75050930.11
    Remove: psa-mnemo.noarch 0:2.0.1-fc2.build75050824.12
    Remove: psa-passwd.noarch 0:3.0-fc2.build75050824.12
    Remove: psa-prevztune.i386 0:1.0-3.swsoft
    Remove: psa-turba.noarch 0:2.0.3-fc2.build75050926.17
    Remove: psa-vpn.i586 0:1.0.0-fc2.build75050824.12
    Remove: psa-vztune.i386 0:1.0-5.swsoft
    Remove: psa-watchdog.i586 0:1.0.0-fc2.build75050926.17

    .. after trying a new udate i got

    Error: Missing Dependency: php = 4.3.11-1.fc2.4.legacy is needed by package php-domxml
    Error: Missing Dependency: libmysqlclient.so.14 is needed by package php-mysql

    again, it seems that yum does not like that the installed versions are *.1.swsoft
     
  19. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Yep, its definitely not pretty. You've got to remove it manually, you probably wont be able to use yum.
     
  20. sybersnake

    sybersnake Guest

    0
     
    dependencies are driving me nuts

    [root@digisoftstudios etc]# rpm -e php-4.3.11-1.fc2.3.legacy.1.swsoft php-xmlrpc-4.3.11-1.fc2.3.legacy.1.swsoft php-snmp-4.3.11-1.fc2.3.legacy.1.swsoftt php-mysql-4.3.11-1.fc2.3.legacy.1.swsoft php-mbstring-4.3.11-1.fc2.3.legacy.1.swsoft php-imap-4.3.11-1.fc2.3.legacy.1.swsoft php-domxml-4.3.11-1.fc2.3.legacy.1.swsoft php-pear-4.3.11-1.fc2.3.legacy.1.swsoft php-snmp-4.3.11-1.fc2.3.legacy.1.swsoft
    error: package php-snmp-4.3.11-1.fc2.3.legacy.1.swsoftt is not installed
    error: Failed dependencies:
    php is needed by (installed) psa-prevztune-1.0-3.swsoft
    php >= 4.0 is needed by (installed) psa-7.5.4-fc2.build75050824.12
    php >= 4.3.0 is needed by (installed) psa-horde-3.0.5-fc2.build75050824.12
    /usr/bin/php is needed by (installed) psa-horde-3.0.5-fc2.build75050824.12
    /usr/bin/php is needed by (installed) psa-kronolith-2.0.3-fc2.build75050824.12
    /usr/bin/php is needed by (installed) psa-turba-2.0.3-fc2.build75050926.17
    php-mysql is needed by (installed) psa-7.5.4-fc2.build75050824.12
    php-mysql is needed by (installed) psa-horde-3.0.5-fc2.build75050824.12
    php-imap is needed by (installed) psa-7.5.4-fc2.build75050824.12
    php-imap is needed by (installed) psa-imp-4.0.3-fc2.build75050824.12
    php-domxml is needed by (installed) psa-horde-3.0.5-fc2.build75050824.12
    [root@digisoftstudios etc]#


    Error: Missing Dependency: php = 4.3.11-1.fc2.4.legacy is needed by package php-domxml
    Error: Missing Dependency: libmysqlclient.so.14 is needed by package php-mysql

    again, it seems that yum does not like that the installed versions are *.1.swsoft
     
Loading...