1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

plesk 8.1, unbuntu 6.06LTS server and Php5...

Discussion in 'Plesk for Linux - 8.x and Older' started by gwendal, Dec 14, 2006.

  1. gwendal

    gwendal Guest

    0
     
    hi everyone


    i explain my problem :

    i've installed plesk 8.1 on a fresh install of ubuntu 6.06 LTS

    then i tried to upgrading php from 4 to 5 :
    and then apt says that he will remove a lot of psa packages... if i aggree the update, of course, plesk doesn't work ...

    how could i do to install php 5 without breaking plesk ? I don't understand why plesk doesn't install php5 natively because php5 packages are int the official repository of ubuntu ....


    can anyone help me ? thanks :)
     
  2. Vengent

    Vengent Guest

    0
     
    I did this on debian rather than ubuntu, but should be very similiar.

    I had to remove libapache-mod-php4 with dpkg using forcedepends (I think, can't remember exact command)

    then installed php5, the psa depended on mod-php4 || mod-php5.

    So once it was gone, and the other in place, has worked okay.
     
  3. gwendal

    gwendal Guest

    0
     
    thanks for answering me

    i've done it on debian but there is still a problem : php doesn't work on my websites. plesk works well.

    psa seems to depends on php4 but doesn't see php5...
     
  4. Vengent

    Vengent Guest

    0
     
    Is it trying to download the php files rather than process them?

    If so, you need to renable the php mod in apache.

    Use a2enmod php5 (assuming that works the same on ubuntu)

    If its not that, i'm afraid i'm out of ideas. G'luck wth it.
     
  5. gwendal

    gwendal Guest

    0
     
  6. Vengent

    Vengent Guest

    0
     
    So the main difference was to use wget, and dpkg rather than apt?
     
  7. gwendal

    gwendal Guest

    0
     
    i had some problems when i tried to use apt-get because of broken dependancies. that's why i use wget and dpkg.

    thanks a lot for your help :)

    i 've just made this turorial for people who have the same problem and would like something clear.
     
  8. ruluk7

    ruluk7 Guest

    0
     
    php5 on ubuntu doesn't work without breaking system

    hi all

    i'm trying to install plesk 8.1 in a virtuozzo VPS with the delivered EZ templates from swsoft. PHP is delivered in version 5 what we need.

    but, after installing plesk, libapache2-mod-php5 is being replaced by libapache2-mod-php4.

    if following the howto described above, the ubuntu system is broken and apt-get upgrade doesn't work anymore:
    Code:
    root@test:/root# apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      psa: Depends: psa-php4-configurator but it is not installed or
                    psa-php5-configurator but it is not installed
    E: Unmet dependencies. Try using -f.
    

    the psa-php5-configurator is not installable in any way to resolve the missing dependencies... but because it's there, there must be an 'official' way how to activate PHP5 (which is already installed, except libapache2-mod-php5)

    does anybody has an idea how to achieve this?

    thanks and best regards.
    lukas.
     
  9. gwendal

    gwendal Guest

    0
     
  10. ruluk7

    ruluk7 Guest

    0
     
    this doesn't help, as mentioned above:

    Code:
    root@test:/root# apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      libapache2-mod-php5: Depends: php5-common (= 5.2.0-0.dotdeb.3) but 5.1.2-1ubuntu3.4 is installed
      psa-php4-configurator: Depends: libapache2-mod-php4 (>= 4:4.3.10) but it is not installable
                             PreDepends: libapache2-mod-php4 but it is not installable
    E: Unmet dependencies. Try using -f.
    
    ...

    i'm waiting now for technical support of swsoft which is not known to be the fastest...
     
  11. gwendal

    gwendal Guest

    0
     
    you should use the official ubuntu repository instead of the dotdeb one :

    try :

    #dpkg -r --force-depends libapache2-mod-php5

    (to remove pakage from dotdeb)

    then find the "libapache2-mod-php5" package in ubuntu repository,

    donwload it with wget and then install it with #dpkg -i --force-depends <PackageName>
     
  12. ruluk7

    ruluk7 Guest

    0
     
    already tried that... doesn't work either, because of the same reason:

    psa-php4-configurator complains about the missing libapache2-mod-php4 which is not installed anymore. this is the main problem i don't get through...

    regards
     
  13. gwendal

    gwendal Guest

    0
     
    change your /etc/apt/sources.list and add :
    deb http://autoinstall.plesk.com/debian PSA_8.0.0/ (change with the walue fo ubuntu)

    and try


    #dpkg --force-depends -r psa-php4-configurator
    #apt-get update
    #apt-get install psa-php5-configurator
     
  14. ruluk7

    ruluk7 Guest

    0
     
    already tried that several times with no success:

    Code:
    root@test:/# cat /etc/apt/sources.list
    
    deb [url]http://autoinstall.plesk.com/ubuntu/PSA_8.1.0[/url] dapper all
    
    root@test:/# dpkg --force-depends -r psa-php4-configurator
    dpkg: psa-php4-configurator: dependency problems, but removing anyway as you request:
     psa depends on psa-php4-configurator | psa-php5-configurator; however:
      Package psa-php4-configurator is to be removed.
      Package psa-php5-configurator is not installed.
    (Reading database ... 59609 files and directories currently installed.)
    Removing psa-php4-configurator ...
    
    root@test:/# apt-get update
    Ign [url]http://autoinstall.plesk.com[/url] dapper Release.gpg
    Ign [url]http://autoinstall.plesk.com[/url] dapper Release
    Ign [url]http://autoinstall.plesk.com[/url] dapper/all Packages
    Hit [url]http://autoinstall.plesk.com[/url] dapper/all Packages
    Reading package lists... Done
    
    root@test:/# apt-get install psa-php5-configurator
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      psa-php5-configurator: Depends: libapache2-mod-php5 but it is not installable
                             Depends: php5-mysql but it is not going to be installed
                             Depends: php5-curl but it is not going to be installed
                             PreDepends: libapache2-mod-php5 but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
    and if trying to solve the above dependencies, it get's endless... tried that for hours...

    there is no way i could possibly think about...

    thanks anyway!
    regards
     
  15. gwendal

    gwendal Guest

    0
     
    you must install the package : libapache2-mod-php5, php5-mysql, php5-curl

    with wget and dpkg -i --force-depends

    an then run apt-get to install psa-php5-configurator
     
  16. ruluk7

    ruluk7 Guest

    0
     
    AS SAID, i tried that already several times... it's not working, because there are other dependencies afterwards which can not be resolved.

    i'm not a newbie, believe me. and i tried all these possibilities for HOURS!

    it sucks that SWsoft is not able to provide software which is installable out of the box. all i would expect from a buyied and licensed software would be a 'apt-get install psa-php5-configurator' and nothing more.

    at least there IS a php5-way, otherwise this configurator-thing would not exist, right?? so SWsoft should support it!

    unfortunately, they don't reply to support requests in reasonable time... :(


    and - obviously, nobody else has solved this problem successfully without any workarounds.

    hoping for the support.
     
  17. gwendal

    gwendal Guest

    0
     
    ok well, it works for me

    but it was on plesk 8.0.0 and debian

    perhaps that's because it doesn't work for you ...
     
  18. Vengent

    Vengent Guest

    0
     

    I also have it working on debian, with php5 and plesk 8.1

    It requires a couple of force depends, but it is very easy to work through it. Not even really a workaround, just bypassing a || package dependency that is misconfigured.

    If you're willing to actually try stuff, I'm sure people here can help, otherwise, support sounds like your better option.
     
  19. ruluk7

    ruluk7 Guest

    0
     
    i might have been a little bit rude in my last mail. i would apologize for that...

    the thing is, that i'm trying really hard and if i would not be willing to try and to let people help me, i wouldn't have written into this board...

    but - as i suppose - ubuntu is a little bit different with the package dependencies as debian is. and probably, plesk isn't the same if it is installed through virtuozzo or if it is installed with the autoinstaller.

    at least i didn't get php5 running while not breaking any dependency the way 'apt-get upgrade' would still work.

    and i was trying at least in 6 newly created VPS from scratch for at least six hours... yes, these figures mean nothing. but at least it shows some effort...

    i will try it again and post some console logs that you see what happens...

    regards
     
  20. ruluk7

    ruluk7 Guest

    0
     
    ok. after installing the following:
    Code:
    root@test:/# apt-get install psa-php5-configurator
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      psa-php5-configurator: Depends: libapache2-mod-php5 but it is not installable
                             Depends: php5-mysql but it is not going to be installed
                             Depends: php5-curl but it is not going to be installed
                             PreDepends: libapache2-mod-php5 but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
    
    root@test:~# wget [url]http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-mysql_5.1.2-1ubuntu3.4_i386.deb[/url]
    --19:50:46--  [url]http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-mysql_5.1.2-1ubuntu3.4_i386.deb[/url]
               => `php5-mysql_5.1.2-1ubuntu3.4_i386.deb'
    Resolving security.ubuntu.com... 82.211.81.138
    Connecting to security.ubuntu.com|82.211.81.138|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 22,000 (21K) [application/x-debian-package]
    
    100%[============================================================================>] 22,000        --.--K/s             
    
    19:50:47 (285.12 KB/s) - `php5-mysql_5.1.2-1ubuntu3.4_i386.deb' saved [22000/22000]
    
    root@test:~# dpkg -i --force-depends php5-mysql_5.1.2-1ubuntu3.4_i386.deb 
    Selecting previously deselected package php5-mysql.
    (Reading database ... 59607 files and directories currently installed.)
    Unpacking php5-mysql (from php5-mysql_5.1.2-1ubuntu3.4_i386.deb) ...
    dpkg: php5-mysql: dependency problems, but configuring anyway as you request:
     php5-mysql depends on php5-mysqli (= 5.1.2-1ubuntu3.4); however:
      Package php5-mysqli is not installed.
    Setting up php5-mysql (5.1.2-1ubuntu3.4) ...
    
    root@test:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      php5-mysql: Depends: php5-mysqli (= 5.1.2-1ubuntu3.4) but it is not installed
      psa: Depends: psa-php4-configurator but it is not installed or
                    psa-php5-configurator but it is not installed
    E: Unmet dependencies. Try using -f.
    root@test:~# wget [url]http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-mysqli_5.1.2-1ubuntu3.4_i386.deb[/url]
    --19:51:24--  [url]http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-mysqli_5.1.2-1ubuntu3.4_i386.deb[/url]
               => `php5-mysqli_5.1.2-1ubuntu3.4_i386.deb'
    Resolving security.ubuntu.com... 82.211.81.138
    Connecting to security.ubuntu.com|82.211.81.138|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 37,366 (36K) [application/x-debian-package]
    
    100%[============================================================================>] 37,366        --.--K/s             
    
    19:51:24 (432.90 KB/s) - `php5-mysqli_5.1.2-1ubuntu3.4_i386.deb' saved [37366/37366]
    
    root@test:~# dpkg -i --force-depends php5-mysqli_5.1.2-1ubuntu3.4_i386.deb 
    Selecting previously deselected package php5-mysqli.
    (Reading database ... 59609 files and directories currently installed.)
    Unpacking php5-mysqli (from php5-mysqli_5.1.2-1ubuntu3.4_i386.deb) ...
    Setting up php5-mysqli (5.1.2-1ubuntu3.4) ...
    root@test:~# wget [url]http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-curl_5.1.2-1ubuntu3.4_i386.deb[/url]
    --19:52:09--  [url]http://security.ubuntu.com/ubuntu/pool/main/p/php5/php5-curl_5.1.2-1ubuntu3.4_i386.deb[/url]
               => `php5-curl_5.1.2-1ubuntu3.4_i386.deb'
    Resolving security.ubuntu.com... 82.211.81.138
    Connecting to security.ubuntu.com|82.211.81.138|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 22,842 (22K) [application/x-debian-package]
    
    100%[============================================================================>] 22,842        --.--K/s             
    
    19:52:09 (371.01 KB/s) - `php5-curl_5.1.2-1ubuntu3.4_i386.deb' saved [22842/22842]
    
    root@test:~# dpkg -i --force-depends php5-curl_5.1.2-1ubuntu3.4_i386.deb 
    Selecting previously deselected package php5-curl.
    (Reading database ... 59611 files and directories currently installed.)
    Unpacking php5-curl (from php5-curl_5.1.2-1ubuntu3.4_i386.deb) ...
    Setting up php5-curl (5.1.2-1ubuntu3.4) ...
    
    
    root@test:~# wget [url]http://security.ubuntu.com/ubuntu/pool/main/p/php5/libapache2-mod-php5_5.1.2-1ubuntu3.4_i386.deb[/url]
    --19:52:51--  [url]http://security.ubuntu.com/ubuntu/pool/main/p/php5/libapache2-mod-php5_5.1.2-1ubuntu3.4_i386.deb[/url]
               => `libapache2-mod-php5_5.1.2-1ubuntu3.4_i386.deb'
    Resolving security.ubuntu.com... 82.211.81.138
    Connecting to security.ubuntu.com|82.211.81.138|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 2,259,902 (2.2M) [application/x-debian-package]
    
    100%[============================================================================>] 2,259,902      1.08M/s             
    
    19:52:53 (1.07 MB/s) - `libapache2-mod-php5_5.1.2-1ubuntu3.4_i386.deb' saved [2259902/2259902]
    
    
    root@test:~# dpkg -r --force-depends libapache2-mod-php4                                                               
    (Reading database ... 59611 files and directories currently installed.)
    Removing libapache2-mod-php4 ...
    Module php4 disabled; run /etc/init.d/apache2 force-reload to fully disable.
    root@test:~# dpkg -i --force-depends libapache2-mod-php5_5.1.2-1ubuntu3.4_i386.deb 
    (Reading database ... 59611 files and directories currently installed.)
    Unpacking libapache2-mod-php5 (from libapache2-mod-php5_5.1.2-1ubuntu3.4_i386.deb) ...
    Setting up libapache2-mod-php5 (5.1.2-1ubuntu3.4) ...
    
    
    root@test:~# apt-get install psa-php5-configurator
    Reading package lists... Done
    Building dependency tree... Done
    The following NEW packages will be installed:
      psa-php5-configurator
    0 upgraded, 1 newly installed, 0 to remove and 14 not upgraded.
    Need to get 16.3kB of archives.
    After unpacking 147kB of additional disk space will be used.
    WARNING: The following packages cannot be authenticated!
      psa-php5-configurator
    Install these packages without verification [y/N]? y
    Get:1 [url]http://autoinstall.plesk.com[/url] dapper/all psa-php5-configurator 1.1.0-ubuntu6.06.build81061129.23 [16.3kB]
    Fetched 16.3kB in 1s (12.5kB/s)            
    Selecting previously deselected package psa-php5-configurator.
    (Reading database ... 59613 files and directories currently installed.)
    Unpacking psa-php5-configurator (from .../psa-php5-configurator_1.1.0-ubuntu6.06.build81061129.23_all.deb) ...
    Setting up psa-php5-configurator (1.1.0-ubuntu6.06.build81061129.23) ...
    ===> configuring php5 using /etc/php5/apache2/php.ini file
     Trying to set memory limit to 32M... done
     Trying to add '.' to 'include_path'... Unable to find 'include_path' variable in /etc/php5/apache2/php.ini
    Adding new entry
    done
     Trying to set 'short_open_tag' to On... done
     Trying to set 'file_uploads' to On... done
     Trying to set 'safe_mode' to On... done
    ===> configuring php5 using /etc/php5/cli/php.ini file
     Trying to set memory limit to 32M... done
     Trying to add '.' to 'include_path'... Unable to find 'include_path' variable in /etc/php5/cli/php.ini
    Adding new entry
    done
     Trying to set 'short_open_tag' to On... done
     Trying to set 'file_uploads' to On... done
     Trying to set 'safe_mode' to On... done
    
    root@test:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    The following packages have been kept back:
      php5 php5-cgi php5-cli php5-common php5-curl php5-gd php5-ldap php5-mhash php5-mysql php5-mysqli php5-odbc
      php5-recode php5-xmlrpc php5-xsl
    0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
    
    as you can see, psa-php5-configurator is successfully installed now, but php5 doesn't get upgraded anymore. so no more security upgrades or anything...

    if trying a dist-upgrade, plesk would get de-installed:
    Code:
    root@test:~# apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree... Done
    Calculating upgrade... Done
    The following packages will be REMOVED:
      libapache2-mod-php5 libpam-plesk php5-snmp php5-sybase psa psa-api psa-api-rpc psa-horde psa-hotfix3 psa-hotfix4
      psa-imp psa-ingo psa-kronolith psa-manual-custom-skin-guide psa-migration-manager psa-mimp psa-mnemo psa-passwd
      psa-php5-configurator psa-turba psa-updates
    The following packages will be upgraded:
      php5 php5-cgi php5-cli php5-common php5-curl php5-gd php5-ldap php5-mhash php5-mysql php5-mysqli php5-odbc
      php5-recode php5-xmlrpc php5-xsl
    14 upgraded, 0 newly installed, 21 to remove and 0 not upgraded.
    Need to get 7159kB of archives.
    After unpacking 262MB disk space will be freed.
    Do you want to continue [Y/n]?
    
    so, any tipps?

    thanks and regards
     
Loading...