1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

plesk 9.0 the source for backscatter!

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by 105547111, Jan 13, 2009.

  1. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    How many of you see emails from mailer daemon stuck in your mail queue?

    How many are for some non existent dfgsdgd@ user at your domains? (this I can fix do the mod below)

    After spending days and days, the postfix users have told me that its the way plesk is handling spam that is causing 'backscatter'.

    Bouncing spam instead of deleting it. These bounces then get stuck in the outgoing mailserver queue as they are all spam and undeliverable.

    This makes anyone using plesk a source of backscatter and that is really BAD you can get blacklisted for doing this.

    This needs to be addressed ASAP. Its something in 9 the way it handles mail has changed since the other versions.

    The issue is you don't bounce SPAM - ever.

    So far I have minimised it by rejecting spam for users that are NOT on the server by editing /etc/postfix/main.cf:

    # REJECTING MAIL FOR UNKNOWN LOCAL USERS
    local_recipient_maps = $virtual_mailbox_maps

    #smtpd_sender_restrictions = check_sender_access hash:/var/spool/postfix/plesk/blacklists
    smtpd_sender_restrictions = check_sender_access hash:/var/spool/postfix/plesk/blacklists, reject_non_fqdn_sender, reject_unauthenticated_sender_login_mismatch

    Thanks!

    David
     
  2. gshelton

    gshelton Guest

    0
     
    Thank you. I have implimented your suggestions and will watch to see what happens.
     
  3. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    It helps, but as I said it wont stop it. But atleast now your not backscattering non existent addresses on your server, I cut back from 50 a day to about 4 to 6 :)

    But we need a proper fix from plesk they should not be bouncing bloody spam!

    Also now guess what, if you had a mailbox with no redirects or groups and mailbox, it now bloody sends a bounce email so now you cant blackhole email!

    Stupid to say the least as if you create a mailbox and dont forward it anywhere it should not bounce!
     
  4. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    Im sorry if this isnt terribly helpful - I dont use Plesk email becuase it has always sucked, but isnt there an option somewhere to black hole email delivered to non existant domains and addresses instead of bouncing?

    Does this help?

    Code:
    letters sent to a nonexistent mailname, are bounced with this phrase
    /usr/local/psa/admin/bin/mailmng --set-bounce --domain-name=<domain> --phrase=<phrase>
    
    You could run it in a script against all your domains
    Code:
    mysql -Ns -uadmin -p`cat /etc/psa/.psa.shadow` -Dpsa -e  "select name from domains" > /tmp/list 
    for domain in `cat /tmp/list` ; do 
    /usr/local/psa/admin/bin/mailmng --set-bounce --domain-name=$domain --phrase=<phrase>
    done
    
    And then you can setup an event handler to do that to each new domain

    Not sure if that really helps you at all
     
  5. ziba@

    ziba@ Guest

    0
     
    Hi,

    In Plesk there are several options on what to do with mail to non-existent users:
    # Continue returning all such mail back to senders (Bounce option),
    # Forward all such mail to the specified e-mail address (Catch to address option),
    # Forward all such mail to another mail server with the specified IP address (Redirect to external mail server with IP address option),
    # Reject such mail without accepting it and without notifying senders (Discard option).

    It is configured on per domain level:
    http://download1.parallels.com/Plesk/PPP9/Doc/en-US/plesk-9.0-administrators-guide/toc58805234.htm

    Generally recommended configuration is to reject such emails - this prevents excessive load on mail server.

    You can change this setting for multiple domains at once by selecting domains on Domains page on clicking on 'Modify' button.
     
  6. gshelton

    gshelton Guest

    0
     

    This is all correct... The problem is Plesk 9 is junk and fails to do what it is supposed to do. It does not work correctly.
     
Loading...