1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 9.2.1 (Windows) Backup Transfer to FTP issue.

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by AtulA, Aug 25, 2009.

  1. AtulA

    AtulA Guest

    0
     
    We're facing an issue with Plesk backup manager here are the details -

    Problem Details: We've scheduled the daily backup task in the backup manager. And its configured to transfer the backup to our FTP server. The problem is that we're receiving failed backup notifications in the mail with following error -



    <?xml version="1.0" encoding="utf-8"?>

    <execution-result status="error">

    <object name="backup" type="backupowner">

    <message code="ApplicationException" severity="error">Cannot export dump file 'Full-Daily_info_0908160100.xml' to 'ftp://myFTPserver/' [Transport error: unable to send directory to repository: Transport error: unable to put local file C:/WINDOWS/TEMP/repo_transport_tmp_01ca1e2f020c7ef0/full-daily_0908160100.zip to full-daily_0908160100.zip: Curl error: a timeout was reached]</message>

    </object>

    </execution-result>



    Here are the Technical details Of the server, You may need:

    Plesk Version : 9.2.1
    Operating system : Windows Server 2003 Standard Edition

    We've searched and found a solution in parallels Forum:

    http://forum.parallels.com/showthread.php?t=87685
    http://forum.parallels.com/showthread.php?t=90033
    http://kb.odin.com/en/6135

    The solutions specified on above links are for older versions (9.0, 9.1), so theyre not working on Please 9.2.1. Please suggest if there is any working solution for this problem. Thanks
     
  2. MichaelMajor

    MichaelMajor Guest

    0
     
    I am also having the same problem with the same config. Have reviewed other postings of same problem with solutions for 9.0 and 9.1 but wouldn't this have been fixed with 9.2.1? Have looked at http://kb.odin.com/en/6135 but that package only has a DLL for 9.1 and it appears the psarepository.dll file in my 9.2.1 in newer. Had a look in the registry key and couldn't find FtpRequestTimeOut.
     
  3. AtulA

    AtulA Guest

    0
     
    I even createad the regsitry key along with other steps, as specified in http://kb.odin.com/en/6135 , still facing the same problem. I think its a bug. Can anybody help ??
     
  4. MichaelMajor

    MichaelMajor Guest

    0
     
    I have a temporary fix for this as I've just set my backups for multivolume backups. My FTP uploads seems to time out around 35 Mb so I set it for around 30 Mb and the FTP upload seems to be complete. Still need to get a fix for this since it's impractical to have 30 Mb backups on a 15 Gb full backup!.
     
  5. SistemasC

    SistemasC Guest

    0
     
    Got the same problem

    Hi:

    I got the same error when copying a backup using FTP when the size of the file is around 100MB.
    I've tried to use the command-line command "FTP", and it works fine.
    So, it seems a problem of the Plesk software.

    Any ideas?
    Thanks in advance...
     
  6. SistemasC

    SistemasC Guest

    0
     
    Got the same problem!!!

    While running a backup using FTP it fails when the size of the file reaches about 100MB.
    I've tried to make the backup using the command-line command "ftp" and it works fine.
    So, it seems a problem of the Plesk software.

    Any ideas somebody of the "Plesk team"???
    Thanks in advance...
     
  7. Adam Dresch

    Adam Dresch Guest

    0
     
    I setup the FTP backups for the first time tonight, it didn't accept the @ symbol in the username to start with
    Additionally, when doing a FULL Server backup to the FTP repository, it didn't work at all
    It said the backup was complete, but it never emailed the report, nor did it upload the backup file?
    I've just run one through the domain area and it IS uploading it, but gawd, it's going at a paltry 156kb/sec
    Where as I should be getting in excess of 1MB a second.
     
  8. Adam Dresch

    Adam Dresch Guest

    0
     
    I'm getting the same problem to, it transfers 98mb and then stops.
     
  9. SistemasC

    SistemasC Guest

    0
     
    CURIOUS: Time it takes to timeout: 10 minutes

    Hi:

    This error seems to be related with the duration of the backup because it always takes 10 minutes to fail.
    The size of the file copied depends on how many time is necessary to copy by ftp the file.
    If it takes less than 10 minutes, the backup finishes successfully and the whole file is copied.
    Otherwise, if it takes more than 10 minutes, we got the timeout error. If we check the file, it's copied until the moment of the timeout. The size of the file may vary depending on the available bandwith.

    PLESK TEAM: I've seen some threads talking about this problem and they were created several months ago and there is no solution for Plesk 9.2.1...
    ANY IDEAS?

    Regards
     
  10. SistemasC

    SistemasC Guest

    0
     
    More information about this...

    I've captured the FTP traffic using Wireshark on the Plesk server and i've seen the server sends an TCP packet with the flags RST/ACK on.
    So the software that uploads the backup OR the PHP interpreter are who finish the TCP connection EXACTLY 10 MINUTES after the begginig of the file transfer.

    It seems a bug on the PHP code of the Plesk software that uploads the file OR a wrong configuration somwhere else (PHP interpreter, for example) is the origin of the timeout.

    I've seen another comment published on May 2009 where a member of the Parallels team says a solution is on the way... but it was several months ago and the problem doesn't seem resolved...

    WHAT CAN WE DO???
     
  11. SistemasC

    SistemasC Guest

    0
     
    Problem resolved!!! :)

    Hi:

    Following the instructions in this web page: http://kb.odin.com/en/6135 :
    It seems that the default configuration is to timeout an ftp transfer of a backup file when it takes more than 600 seconds (10 minutes) to finish.
    With this change, you can set the timeout to more than the time it takes to backup the biggest backup on your server...

    I've open the Windows registry path "HKEY_LOCAL_MACHINE\SOFTWARE\PLESK\PSA Config\Config"
    and created the "FtpRequestTimeOut" DWORD key with a value of "60000" seconds (about 16,6 hours).

    I did NOT update the DLL file "psarepository.dll" on my server, I JUST created the registry key.
    Now the backups that takes more than 10 minutes to finish and which size are 300-600MB are running fine and they finish without problems.


    Regards.
     
  12. mikelegg

    mikelegg Guest

    0
     
    I've taken the same steps but I'm still getting the "Curl error: a timeout was reached" message.

    On the plus side, I'm no longer getting 20Gb of files left on my web server every day which I had to delete manually, so that's a small improvement.

    The strange thing is that despite the error, the backup file IS being FTP'd to my backup server.
     
  13. SistemasC

    SistemasC Guest

    0
     
    ONLY works with manual backups!!!

    Hi again:

    I've realized that the fix I posted before ONLY WORKS with MANUAL backups.
    The scheduled backups fail even applying the registry change.

    Any ideas?
     
  14. SistemasC

    SistemasC Guest

    0
     
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  15. SistemasC

    SistemasC Guest

    0
     
    Hi again!!!

    I tried to replace the DLL with the DLL for Plesk 9.1 as explained in http://kb.odin.com/en/6135
    in my Plesk 9.2.1 but it didn't work for me.
    So I restored the original DLL.

    I'm going to try to schedule backups using command pleskbackup.exe to see if works.

    Regards
     
  16. SistemasC

    SistemasC Guest

    0
     
    Sorry, it only works with manual backups... :(
    The scheduled backups are still failing...
     
  17. SistemasC

    SistemasC Guest

    0
     
    Hi:

    I'm trying to make scheduled backups using commmand-line as explained here:
    http://download1.parallels.com/Ples...backup-cli-guide/index.htm?fileName=62059.htm
    In this document, I couldn't find the parameters to make a backup using FTP.

    Can I have the parameters to make backups by FTP using the command-line commands?

    Thanks in advance.

    BTW: The only way I've found to make a scheduled backup using FTP is to make scheduled local backups, and then copy the local respository folder to a FTP using a backup software like Cobian.
     
  18. SistemasC

    SistemasC Guest

    0
     
  19. RutgerH

    RutgerH New Pleskian

    19
    85%
    Joined:
    Nov 27, 2009
    Messages:
    17
    Likes Received:
    0
    Hi SitemasC,

    We upgraded some servers to plesk 9.2.3 and on two servers we have the problem you described.
    I've replaced the psarepository.dll with the 9.2.1 version and indeed no luck. I'm now going to try the reg key, i'll get back to you when the backup is finished...Wish me luck ;-)
     
  20. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Look at FTP options here.
     
Loading...