1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 9.5.4 upgrade to 11x - mysql-libs removal error

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Katana, Sep 26, 2012.

  1. Katana

    Katana New Pleskian

    22
    73%
    Joined:
    Apr 12, 2007
    Messages:
    17
    Likes Received:
    0
    Hello everybody,

    I already have done three upgrades on similar servers (Centos 5x) from Plesk 9.5.4 to 11x version and everything went fine and without any problems. Then came upgrade for server no.4 and I got following error:

    A dependency problem is found: required package mysql-5.0.95-1.el5_7.1.x86_64 conflicts with mysql-libs-5.0.86-1.el5.art.x86_64. No upgrade or obsolete solution was found for mysql-libs. Try to add mysql-libs to removable list.
    Problem occured during searching conflicts for package mysql-5.0.95-1.el5_7.1.x86_64
    Execute command /usr/local/psa/admin/bin/send-error-report install
    Error: Unable to proceed with the installation until the package mysql-libs-5.0.86-1.el5.art.x86_64 is removed from the system.
    Not all packages were installed.
    Please resolve this issue and try installing the packages again.
    If you cannot resolve the issue on your own, contact product technical support for assistance.


    Of course, I can't remove mysql-libs or else I will kill Plesk. So, can I upgrade mysql via yum to 5.0.95 version (from 5.0.86) or maybe to force remove mysql-libs package without removing dep or something?

    Thanks,
    Igor
     
  2. Katana

    Katana New Pleskian

    22
    73%
    Joined:
    Apr 12, 2007
    Messages:
    17
    Likes Received:
    0
    So, no suggestions yet?
    Let me rephrase it then - Is it safe to manually update mysql to the version required by Plesk before auto-update to 11x?
     
Loading...