1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk funktioniert nach update nicht mehr

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by zerefenikus, Nov 3, 2010.

  1. zerefenikus

    zerefenikus Guest

    0
     
    Hallo Leute!

    Ich habe mein Plesk auf die version 10.0.0 upgegraded aber nun startet mir plesk nicht mehr. Email dienste laufen usw aber plesk selbst also sw-cp-server lässt sich nicht mehr starten. Ich suche schon ständig im internet nach lösungen und finde nichts.

    Das blöde ist das mir plesk in den error files nichts hineinschreibt.

    Plesk ist bei mir auf Centos 64 bit installiert bei 1 und1 Server.

    Achja ich habe das update im Panel gestartet aber ich hab dan längers keine meldung mehr bekommen daher hab ich dan gesehen das sich das Update aufgehängt hat. Ich habe dann das update manuell mit diesen Befehl gemacht:

    Code:
     /usr/local/psa/admin/bin/autoinstaller
    
    hab alles auf standart gelassen, 10.0.0 ausgewählt und dann später kam der fehler, also dort wo sich dan plesk auch vermutlich vom panel aus aufgehängt hatte:

    Code:
    ....
    Installing the package hspc-plugin-rpc-3.3.3-10090115.x86_64
    chown: `hspc.hspc': invalid user
      => [register factory] 'plugin-rpc'
    => [error on previous startup] Can't continue upgrade process
    error: %post(hspc-plugin-rpc-3.3.3-10090115.x86_64) scriptlet failed, exit status 255
    
    ERROR: An error occurred during installation of packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    

    ich hab dan einfach bei der module auswahl 8 und 10 deaktiviert und dan liefs normal durch aber geht immer noch ned..

    Code:
    Show components for the product:
    
    1. (*) Parallels Plesk Panel  ........ 1 of 31 components selected
    2. ( ) Sitebuilder  ........ 0 of 4 components selected
    
    Please select the components of Parallels Plesk Panel you want to install:
    
     3. [=] Base packages of Plesk
     4. [=] Plesk Updater
     5. [=] PostgreSQL server support
     6. [=] Plesk migration manager
     7. [=] Health monitor
     8. [ ] Additional business plugins for Customer & Business Manager
     9. [=] SiteBuilder
    10. [ ] Customer & Business Manager (free, recommended for shared hosting)
    11. [=] PHP5 support
    12. [=] <+> Plesk hosting features // 7 of 7 components selected
    
      Different mailservers
    13. (=) Qmail mailserver
    14. ( ) Postfix mailserver
    
    15. [.] <+> Additional Plesk modules // 5 of 5 components selected
    16. [=] <+> Game servers // 1 of 1 components selected
    17. [=] <+> Addition mail services // 4 of 4 components selected
    18. [=] <+> Server backup solutions // 2 of 2 components selected
    19. [=] <+> Plesk webmails support // 2 of 2 components selected
    
    N) Next page; P) Go back;  Q) Cancel installing;
    A) Select all; D) Deselect all;
    Enter number to toggle the component or to view the group;
    Type a number or a character of desired action [N]:
    
    

    Wenn ich sw-cp-server starte krieg ich folgende fehlermeldung:

    Code:
    [root@furmania ~]# /etc/init.d/sw-cp-server start
    Starting SWsoft control panels server... stale pidfile.  st[FAILED]ile.
    [root@furmania ~]#
    
    und folgendes bekomme ich mit dem befehl heraus: sh -x /etc/init.d/sw-cp-server start

    Code:
    
    + . /etc/rc.d/init.d/functions
    ++ TEXTDOMAIN=initscripts
    ++ umask 022
    ++ PATH=/sbin:/usr/sbin:/bin:/usr/bin
    ++ export PATH
    ++ '[' -z '' ']'
    ++ COLUMNS=80
    ++ '[' -z '' ']'
    +++ /sbin/consoletype
    ++ CONSOLETYPE=pty
    ++ '[' -f /etc/sysconfig/i18n -a -z '' ']'
    ++ . /etc/profile.d/lang.sh
    +++ sourced=0
    +++ for langfile in /etc/sysconfig/i18n '$HOME/.i18n'
    +++ '[' -f /etc/sysconfig/i18n ']'
    +++ . /etc/sysconfig/i18n
    ++++ LANG=en_US.UTF-8
    ++++ SYSFONT=latarcyrheb-sun16
    +++ sourced=1
    +++ for langfile in /etc/sysconfig/i18n '$HOME/.i18n'
    +++ '[' -f /root/.i18n ']'
    +++ '[' -n '' ']'
    +++ '[' 1 = 1 ']'
    +++ '[' -n en_US.UTF-8 ']'
    +++ export LANG
    +++ '[' -n '' ']'
    +++ unset LC_ADDRESS
    +++ '[' -n '' ']'
    +++ unset LC_CTYPE
    +++ '[' -n '' ']'
    +++ unset LC_COLLATE
    +++ '[' -n '' ']'
    +++ unset LC_IDENTIFICATION
    +++ '[' -n '' ']'
    +++ unset LC_MEASUREMENT
    +++ '[' -n '' ']'
    +++ unset LC_MESSAGES
    +++ '[' -n '' ']'
    +++ unset LC_MONETARY
    +++ '[' -n '' ']'
    +++ unset LC_NAME
    +++ '[' -n '' ']'
    +++ unset LC_NUMERIC
    +++ '[' -n '' ']'
    +++ unset LC_PAPER
    +++ '[' -n '' ']'
    +++ unset LC_TELEPHONE
    +++ '[' -n '' ']'
    +++ unset LC_TIME
    +++ '[' -n '' ']'
    +++ unset LC_ALL
    +++ '[' -n '' ']'
    +++ unset LANGUAGE
    +++ '[' -n '' ']'
    +++ unset LINGUAS
    +++ '[' -n '' ']'
    +++ unset _XKB_CHARSET
    +++ consoletype=pty
    +++ '[' -z pty ']'
    +++ '[' -n '' ']'
    +++ '[' -n '' ']'
    +++ '[' -n en_US.UTF-8 ']'
    +++ case $LANG in
    +++ '[' xterm = linux ']'
    +++ unset SYSFONTACM SYSFONT
    +++ unset sourced
    +++ unset langfile
    ++ '[' -z '' ']'
    ++ '[' -f /etc/sysconfig/init ']'
    ++ . /etc/sysconfig/init
    +++ BOOTUP=color
    +++ GRAPHICAL=yes
    +++ RES_COL=60
    +++ MOVE_TO_COL='echo -en \033[60G'
    +++ SETCOLOR_SUCCESS='echo -en \033[0;32m'
    +++ SETCOLOR_FAILURE='echo -en \033[0;31m'
    +++ SETCOLOR_WARNING='echo -en \033[0;33m'
    +++ SETCOLOR_NORMAL='echo -en \033[0;39m'
    +++ LOGLEVEL=3
    +++ PROMPT=yes
    +++ AUTOSWAP=no
    ++ '[' pty = serial ']'
    ++ '[' color '!=' verbose ']'
    ++ INITLOG_ARGS=-q
    ++ __sed_discard_ignored_files='/\(~\|\.bak\|\.orig\|\.rpmnew\|\.rpmorig\|\.rpmsave\)$/d'
    + DAEMON=/usr/sbin/sw-cp-serverd
    + test -x /usr/sbin/sw-cp-serverd
    + DESC='SWsoft control panels server'
    + PIDFILE=/var/run/sw-cp-server.pid
    + CONFIGFILE=/etc/sw-cp-server/config
    + DAEMONARGS='-f /etc/sw-cp-server/config'
    + case "$1" in
    + echo -n 'Starting SWsoft control panels server...'
    Starting SWsoft control panels server...+ sw_check_pid
    ++ cat /var/run/sw-cp-server.pid
    + pid=
    + '[' 0 -ne 0 ']'
    + '[' '' -gt 0 ']'
    + sw_check_pid_result=STALE
    + return
    + case $sw_check_pid_result in
    + echo -n ' stale pidfile. '
     stale pidfile. + rm -f /var/run/sw-cp-server.pid
    + sw_cpserver_start
    + /usr/sbin/sw-cp-serverd -f /etc/sw-cp-server/config
    + res=255
    + '[' 255 -ne 0 ']'
    + sw_check_pid
    ++ cat /var/run/sw-cp-server.pid
    + pid=
    + '[' 0 -ne 0 ']'
    + '[' '' -gt 0 ']'
    + sw_check_pid_result=STALE
    + return
    + case $sw_check_pid_result in
    + echo -n ' stale pidfile. '
     stale pidfile. + rm -f /var/run/sw-cp-server.pid
    + /usr/sbin/sw-cp-serverd -f /etc/sw-cp-server/config
    + sw_rc_status
    + local ret=255
    + '[' 255 -eq 0 ']'
    + failure
    + local rc=1
    + '[' color '!=' verbose -a -z '' ']'
    + echo_failure
    + '[' color = color ']'
    + echo -en '\033[60G'
                                                               + echo -n '['
    [+ '[' color = color ']'
    + echo -en '\033[0;31m'
    + echo -n FAILED
    FAILED+ '[' color = color ']'
    + echo -en '\033[0;39m'
    + echo -n ']'
    ]+ echo -ne '\r'
    + return 1
    + '[' -x /usr/bin/rhgb-client ']'
    + /usr/bin/rhgb-client --details=yes
    + return 1
    + echo
    
    + return 255
    
    ich bin echt ratlos... und naja mit psa start das hier aber schriebt keine logs halt weil sw-cp-server ned starten kann

    Code:
    [root@furmania ~]# /etc/init.d/psa startall
    Starting psa...                                                      failed
    Starting xinetd service...                                           done
    Starting named service...                                            done
    Starting mysqld service...                                           done
    Starting postgresql service...                                       done
    Starting psa-spamassassin service...                                 done
    Plesk: Starting Mail Server... already started
    
    

    ahchja und wenn ich auf 10.0.1 upgraden will bekomm ich den fehler hier:

    Code:
    `/var/lib/psa/dumps/mysql.preupgrade.dump.gz' -> `/var/lib/psa/dumps/mysql.preupgrade.dump.gz.8'
     Trying to backup MySQL database... done
     MySQL databases are dumped to /var/lib/psa/dumps/mysql.preupgrade.dump.gz
     Checking that /usr/local/psa/bin/chrootsh registered as login shell...
    /usr/local/psa/bin/chrootsh already registered as a login shell
    
    Create PPSB support group
     Checking for the group 'psasb'...
     Group 'psasb' already exists
    
     Checking for the group 'psasb'...
     Trying to add supplementary group 'psasb' for user 'psaadm'...  already there
     Checking for the group 'psasb'...
     Trying to add supplementary group 'psasb' for user 'apache'...  already there
    
    ===> Performing safe prep-install database actions
    
    
    ===> Upgrading database
    
     Trying to start service mysqld... mysqld (pid 2621) is running...
    done
     Trying to establish test connection... connected
    done
     Trying to find psa database... version is 01080
    DATABASE ERROR!!!
    Previous product version is 9.5.2, but previous database
    version is 01080. In most of cases it is result of
    previous upgrade try failure. Please, restore previous version
    from backup, and try again or contact technical support.
    
    ERROR while trying to check database version
    Check the error reason(see log file: /tmp/pp10.9.0-bootstrapper.101103.03.54.log), fix and try again
    
    
    **** Product prep-install failed.
    
    *****  problem report *****
    ERROR while trying to check database version
    Check the error reason(see log file: /tmp/pp10.9.0-bootstrapper.101103.03.54.log), fix and try again
    
    ich weiß nima weiter..
     
  2. MultiServer

    MultiServer New Pleskian

    15
    80%
    Joined:
    Jul 8, 2010
    Messages:
    8
    Likes Received:
    0
    Stelle die letzte Pleskdatenbank aus /var/lib/psa/dumps/mysql.preupgrade.dump.gz
    wieder her, die scheint zerstört zu sein.
     
Loading...