1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Hates MySQL (Rant)

Discussion in 'Plesk for Linux - 8.x and Older' started by rloaderro, Jan 13, 2006.

  1. rloaderro

    rloaderro Guest

    0
     
    I am hoping someone could please explain to me why upgrading Plesk makes installing MySQL 3.23 requisite. Especially since one of the features of P7.5.4 is supposed compatability with MySQL 4.x. It just seems very frustrating to me since there is no way to downgrade MySQL 4.x to 3.x (without dumping the database; removing it and all versions of MySQL; then installing 3.23 clean and re-importing the data. Then - assuming the data is fine and the server is running - updating Plesk only to re-install MySQL 4.x afterwards). WTF. It seems somewhere in the autoupdate - I know, there is always the option of installing the 50 or so RPM's manually - there is a line that reads: if (mysql.ver != 3.23) { install(mysql) } when the line ~should~ be if (mysql.ver < 3.23) { install(mysql) }. That really frustrates me as well because it seems such an obvious error I can't understand why it appears in all the autoupdates for 7.5 - or, for that matter, why autoupdate is a binary instead of a script that I could modify to comment-out the MySQL requirement. Actually, I would love to know why the latest version of Plesk in 2006 uses a version of MySQL from 2001 - with outdated table-types, character-support and syntax, incompatible with many current versions of software.

    Sorry for the long-ish rant, just the result of 12 hours lost to Plesk irreconcilables...
     
Loading...