• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Plesk Hates MySQL (Rant)

R

rloaderro

Guest
I am hoping someone could please explain to me why upgrading Plesk makes installing MySQL 3.23 requisite. Especially since one of the features of P7.5.4 is supposed compatability with MySQL 4.x. It just seems very frustrating to me since there is no way to downgrade MySQL 4.x to 3.x (without dumping the database; removing it and all versions of MySQL; then installing 3.23 clean and re-importing the data. Then - assuming the data is fine and the server is running - updating Plesk only to re-install MySQL 4.x afterwards). WTF. It seems somewhere in the autoupdate - I know, there is always the option of installing the 50 or so RPM's manually - there is a line that reads: if (mysql.ver != 3.23) { install(mysql) } when the line ~should~ be if (mysql.ver < 3.23) { install(mysql) }. That really frustrates me as well because it seems such an obvious error I can't understand why it appears in all the autoupdates for 7.5 - or, for that matter, why autoupdate is a binary instead of a script that I could modify to comment-out the MySQL requirement. Actually, I would love to know why the latest version of Plesk in 2006 uses a version of MySQL from 2001 - with outdated table-types, character-support and syntax, incompatible with many current versions of software.

Sorry for the long-ish rant, just the result of 12 hours lost to Plesk irreconcilables...
 
Back
Top