1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

plesk IIS (PHP?) problem

Discussion in 'Plesk for Windows - 8.x and Older' started by soncek1a, Jan 5, 2007.

  1. soncek1a

    soncek1a Guest

    0
     
    How can i reconfigure IIS with default values for PleskControlPanel? After instalation everything was ok, but later i had to change IIS and add .inc support.

    Now when i start https://212.72.XXX.XXX:8443/ i get HTTP 500 - Internal server error.

    My other domains (plainhtml) i defined before work ok.
    I don't know what to do. Please help me=
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    what do you mean "add .inc support" ?
     
  3. soncek1a

    soncek1a Guest

    0
     
    hmm, i don't know where to start. It is no php problem. i made simple .html page in pleskControlPanel folder and it does not open from browser so iis doesn't serve it.

    first i thought there was a problem in web folder configuration.

    Later i wrote this in cmd:

    C:\Program Files\SWsoft\Plesk\admin\bin>websrvmng.exe --reconfigure-all
    Invalid pointer (COM Error 80004003) at getSiteAppPool(blog.123na.net, )
    C:\Program Files\SWsoft\Plesk\admin\bin>

    so is the reason that i deleted this blog folder manually?
    Any other suggestion how to define problem more speciffic?
     
  4. soncek1a

    soncek1a Guest

    0
     
    ok, i've restored this blog.123na.net folder from recycle bin :) I deleted SitesCache from registry and execute websrvmng.exe --reconfigure-all again and everything was ok. I was even able to made backup of existing projects.

    From explorer i still get "The page can not be displayed". Hmm ...

    Just for info:
    -other webprojects (non SWSoft) on this IIS running ok,
    -all plesk services are running. I've also tried to restart then
     
  5. soncek1a

    soncek1a Guest

    0
     
    now i've removed friendly errors and in browser i've got:
    The file index.php is part of Plesk distribution. It cannot be run outside of Plesk environment.

    I thougt this might be connected with application pool in IIS, but it is on PleskControlPanel. Any other idea?
     
  6. soncek1a

    soncek1a Guest

    0
     
    ok, Here i found solution:
    http://kb.swsoft.com/article_144_1339_en.html

    first i tried to delete licence key later i reconfigure from iis to php. So: It was PHP prob :) :)

    But now there is more: Plesk does not recognize my licence number. I have that exe file with licence. I can not upload it, but when i click on retrieve licence i get:

    License key PLSK.00403635.0000 is up-to-date

    But after OK click there is plsk.00000000.0000 again

    My valid licence no is PLSK.00403635.0000
     
Loading...