1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Important Plesk Onyx 17.5 is now officially released!

Discussion in 'Official Announcements' started by IgorG, Mar 22, 2017.

Thread Status:
Not open for further replies.
  1. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Hi everyone,

    We are happy to announce that Plesk Onyx 17.5 is now officially out and available for installation! To browse the list of new features, latest supported OSes and components, refer to Plesk Onyx 17.5 Release Notes: http://docs.plesk.com/release-notes/current/whats-new/

    We would like to hear your opinion about Plesk Onyx 17.5, especially if you're deploying it on production servers - please let us know what are your favorite features in this release and what would you like to see in the next Plesk version.
     
  2. redhell

    redhell Basic Pleskian

    12
    60%
    Joined:
    Mar 13, 2014
    Messages:
    60
    Likes Received:
    0
    Location:
    Dortmund, Germany
  3. Nextgen-Networks

    Nextgen-Networks New Pleskian

    1
    70%
    Joined:
    Dec 19, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Germany
    Hey Igor,

    i'm running Plesk 10.0.17 Update 20 and facing the FTPS-Backup bug.
    I tried to update to Plesk 17.5 but it's not available in the Plesk installer.

    Is there an possibility to force the upgrade to 17.5?

    I'm running Plesk on an Ubuntu 14.04 system.

    Thanks!
     
  4. G J Piper

    G J Piper Regular Pleskian

    15
    35%
    Joined:
    Dec 8, 2015
    Messages:
    157
    Likes Received:
    29
    I don't show this in the Plesk interface installer either. Is 17.5 considered "stable" like 17.0.17?
     
  5. UFHH01

    UFHH01 Plesk addicted!

    44
    64%
    Joined:
    Jun 11, 2013
    Messages:
    6,762
    Likes Received:
    1,712
    Location:
    Hamburg / Germany
    Hi G J Piper,

    No, this release is certainly (not yet) stable and you will see this only over the Plesk Control Panel, when you use the option "Early adopter release" in your settings at => Home > Tools & Settings > Update and Upgrade Settings

    If you still desire to install the relase on a production server, pls. be informed, that such releases may still have a few bugs here and there.


    Another method of installing/upgrading the releases, is to use the command line ( as user "root" ):

    plesk installer --all-versions

    or

    /usr/local/psa/admin/bin/autoinstaller --all-versions
     
    Dukemaster and G J Piper like this.
  6. Neodork

    Neodork New Pleskian

    3
    20%
    Joined:
    Mar 15, 2017
    Messages:
    6
    Likes Received:
    1
    Location:
    Amsterdam
    Hello Plesk (Igor),

    I am loving the new Onyx installation. Lost one of my Plesk production servers lately due to half-assed firewall configurations and software management. When upgrading to Plesk Onyx I was pleased to notice that features like Fail2Ban, Watchdog (Monit and rkhunter), firewall, ModSecurity, DNSSEC, etc.. Were already integrated and preconfigured, install with the click of a button.
    Because I felt I didn't have enough protection and oversight I added Maltrail manually to Plesk. Writing jails and filters for the observed behaviour was easily done through the Plesk interface. I also find the (Plesk) interface useful to check if the IP address was in fact banned (and by which jails).

    I've installed Plesk Onyx on a Debian that upgraded from 7 to 8 and it runs very smooth. No issues there.

    For me LetsEncrypt SSL certificates and auto-renewal are very useful because it saves me from having to insert and renew certificates manually. However some of my whitelisted domains still need to be manually updated because the whitelist does not allow LE IP's. LE auto-renewal IP's change so now and then and I haven't found a suitable solution yet. Also it might be useful to preconfigure the webmail.example.com domains to be able to automatically renew themselves without having to turn the mail off or configure Nginx with a rule. Or have a checkbox to configure this for the subdomain. Currently the webmail catches the renewal process and it fails.

    So far I haven't been able to get docker running (even with the updated kernel 3.10+). But I expect this to be a problem with my hosting providers virtualization software. You might want to add some extra warning in the documentation about the minimum requirements for the virtualization software the hosting company uses.

    Things I think might need some attention:
    - rkHunter is running version 1.3.4 (think I read somewhere this was going to update).
    - LetsEncrypt being able to auto-renew proxied domains. For example by ignoring the proxy.
    - Running web applications without having to configure Nginx/Apache (I know this is difficult because it's prone to change).
    - Whitelisting certain domains

    So far I am very pleased.

    Kind regards,
    Neodork

    Edit: Move me to 17.0 Onyx feedback thread!
     
    Last edited: Mar 30, 2017
    IgorG likes this.
  7. NKV

    NKV Basic Pleskian

    7
    20%
    Joined:
    Dec 1, 2016
    Messages:
    32
    Likes Received:
    5
    Location:
    Finland
    Then it's going to be stable ver?
     
  8. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
  9. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Have you checked Upgrade Notes - https://docs.plesk.com/release-notes/onyx/upgrade-notes/ ?
     
    Dukemaster likes this.
  10. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    I think that it will be necessary to wait a while :)
    Plesk Onyx 17.0 is stable now.
     
  11. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Yes.
     
  12. NKV

    NKV Basic Pleskian

    7
    20%
    Joined:
    Dec 1, 2016
    Messages:
    32
    Likes Received:
    5
    Location:
    Finland
    Can't wait for LE on subdomains and system resource usage limits :rolleyes:
     
  13. Neodork

    Neodork New Pleskian

    3
    20%
    Joined:
    Mar 15, 2017
    Messages:
    6
    Likes Received:
    1
    Location:
    Amsterdam
    Also I tried to replace my CI with the new git functionality but I am missing some key features. I think if these would be incorporated into the deployment process it would be able to replace my CI:

    - Additional deploy actions don't return feedback (log of what happened). Which makes it hard to debug (or simply check) what happened when you deploy.
    - Unable to determine if the deploy continues when an error occurs (in additional deploy actions) or if it just forces itself onto the new code (looks like forcing).
    - Backing up the database before deploy, and returning it to the backed up state if the deploy fails (when doing additional deploy actions).
    - Configuration file management (for overwriting/specifying environment specific configuration files)

    Things I did like:
    - Instant deployment key generation.
    - Instant webhook url creation.
    - Being able to see commit messages in plesk.
    - Deployment options (No deploy, Manual, Auto).
    (basically everything it has)

    Kind regards,
    Neodork

    Edit: Move me to 17.0 Onyx feedback thread!
     
    Last edited: Mar 30, 2017
  14. G J Piper

    G J Piper Regular Pleskian

    15
    35%
    Joined:
    Dec 8, 2015
    Messages:
    157
    Likes Received:
    29
    If 17.5 isn't stable for the time being, will there still be micro-updates for 17.0.17 coming?
    And if so, won't this page need to be split into two separate pages: Change Log for Plesk
     
  15. Dukemaster

    Dukemaster Regular Pleskian

    18
     
    Joined:
    Nov 21, 2016
    Messages:
    252
    Likes Received:
    36
    Location:
    Rhein-Main - Berlin
    Ubuntu 14.04.5 LTS Plesk 7.0.17 #20 system updated+upgraded+dist-upgrade today.
    Production server successfully upgraded to Plesk 7.5.3 #1
    First over Panel only the Installer Update was installed (Screenshot)
    Running white page.
    Then I tried the installation over Shell.
    Got the following message:
    I decided to better quit the installation because of the risk to have not a stable system according to the 2 required packages.
    After # reboot
    the normal installation over update/upgrade panel was successful.

    Greets and thanks to Plesk for great new features and design...
     

    Attached Files:

    Last edited: Mar 25, 2017
  16. cool_sh

    cool_sh New Pleskian

    3
    20%
    Joined:
    Oct 17, 2016
    Messages:
    23
    Likes Received:
    0
    Location:
    Germany
    Tried to upgrade plesk from current 17 via console to the new 17.5 :

    Preparing Your System for Product Installation
    ===============================================================================
    There are 2 packages required for the product to function properly which were not found in your system.

    There are 62 packages that need to be upgraded in order to install the product.</code

    > Resulted in an error:

    Fatal error during packages installation: [u'ERROR with transaction check vs depsolve:', 'mariadb-server >= 5.0.60 is needed by plesk-mysql-server-17.5.3-cos7.build1705170317.16.x86_64']
    YumRPMCheckError: [u'ERROR with transaction check vs depsolve:', 'mariadb-server >= 5.0.60 is needed by plesk-mysql-server-17.5.3-cos7.build1705170317.16.x86_64']

    ERROR: Failed to run the Yum utility.
    The Yum utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please contact product technical support.
    exit status 1

    > I think this is due to I use Percona MySQL instead of MariaDB. Any idea / workaround to get the update on CentOS 7.3 ?

    Best regards
     
  17. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Yes, we will release microupdates for Plesk Onyx 17.0.17
    Change Log page will not be separated.
     
    Dukemaster likes this.
  18. mrmad

    mrmad New Pleskian

    2
    60%
    Joined:
    Mar 24, 2017
    Messages:
    5
    Likes Received:
    0
    Location:
    Munich
    One thing I noticed when installed the update to 17.5 (I am back to 17.0.17) was that I was not able to select and SAVE :
    Service Plans - Hosting Plans - PHP settings:
    "FPM handler served by nginx"
    It would always revert back to "served by Apache".
    Tested with various php versions (OS, 7.0 and 7.13 on Ubuntu 16.04
    Unfortunately I don't have any logs ( I am totally new to plesk, was using EasyEngine prior to my switch).
    Currently using:
    OS ‪Ubuntu 16.04.2 LTS‬
    Product Plesk Onyx
    Version 17.0.17 Update #20, last updated on Mar 26, 2017 06:05 PM
     
  19. UFHH01

    UFHH01 Plesk addicted!

    44
    64%
    Joined:
    Jun 11, 2013
    Messages:
    6,762
    Likes Received:
    1,712
    Location:
    Hamburg / Germany
    Unconfirmed on our Ubuntu - servers.
     
    Dukemaster likes this.
  20. mrmad

    mrmad New Pleskian

    2
    60%
    Joined:
    Mar 24, 2017
    Messages:
    5
    Likes Received:
    0
    Location:
    Munich
    Okay, so there must be a problem strictly related to my setup? What a pity, but then again I am happy for the community it is not a bug.
    To be more specific, I was able to save the settings but going back to the settings after a while would show "served by Apache"...I am sure you checked the proper settings is still there after a while? :rolleyes:
     
Thread Status:
Not open for further replies.
Loading...