• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Plesk update from 11.5.30 to 12.0.18 "Unable to connect database"

JefersonT

New Pleskian
Hi,

We are trying to upgrade Parallels Plesk Panel from version 5.11.30 to version 12.0.18 and we are getting the following warning:

Code:
"Detectando componentes de produto instalado.
Reunindo informações sobre a chave de licença instalada...
Efetuando download de arquivo PSA_12.0.18/plesk_getkeyinfo.sh: 27%..100% foi concluído.
Efetuando download de arquivo PSA_12.0.18/plesk_getkeyinfo.sh: 100% foi concluído.
Lançamento de verificadores de componentes...
Efetuando download de arquivo PSA_12.0.18/examiners/panel_preupgrade_checker.php: 10%..21%..30%..45%..51%..60%..72%..84%..90%..100% foi concluído.
Efetuando download de arquivo PSA_12.0.18/examiners/php_launcher.sh: 100% foi concluído.

Pelo menos um problema importante foi detectado na validação de componentes:
Parallels Panel pre-upgrade check...
WARNING: [MYSQL ERROR] Unable to connect database. The reason of problem:

Prosseguir com a instalação ou atualização sem resolver os problemas
que foram encontrados pode corromper seus dados.

Deseja prosseguir?
Digitar tanto Sim ou Não: 
[N]: N

The connection to the MySQL server is working. We tested the connection with the following command:

Code:
mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa

Anyone else having this same problem or anyone know how to solve?
 
Somewhere in the upgrade instructions I saw a mention that you might need to restart the mysql server. I can't locate that text right now.
 
Somewhere in the upgrade instructions I saw a mention that you might need to restart the mysql server. I can't locate that text right now.

Hi Steve,

Thanks for your reply, but the MySQL service has been restarted and the warning remained.
 
Back
Top