1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Updater broke for Debian 3.1

Discussion in 'Plesk for Linux - 8.x and Older' started by timw95, Oct 2, 2007.

  1. timw95

    timw95 Guest

    0
     
    I am running Plesk 8.0.1 on Debian 3.1. Currently I am unable to run the Plesk updater. I get the following error message.

    Error: There is no release with ID PLESK_8_0_1.

    I noticed that the following was commented out of the versions.inf3 file located on the http://autoinstall.plesk.com site.

    <build os_name="Linux" os_vendor="Debian" os_version="3.1"
    os_arch="i386" config="PSA_8.0.1/plesk-8.0.1-deb3.1-i386.inf3"/>

    Anybody have an idea why they commented this out and rendered the updater useless.
     
  2. timw95

    timw95 Guest

    0
     
    I should ask anybody know a way to fix this problem?
     
  3. timw95

    timw95 Guest

    0
     
    This is what I got back from Support about this issue.

    A short description is that when 8.0.x Plesk versions were the latest and active, Debian 'stable' branch was oriented to 3.1 Sarge. So that many people set 'stable' in sources.list to have security and system updates accessible.

    However later 'stable' switched to 4.0 Etch. Plesk dependencies were closely bound to several specific Debian 3.1 packages which were either modified or missed in Etch. And right after 'stable' switched to Etch, we started receiving reports that if you update and you have 'stable' in sources.list, some Plesk packages (including the main 'psa' package) are removed due to unsatisfied dependencies, in short words - Plesk installation is destroyed.

    As a huge amount of people used 'stable' updates, to prevent Plesk total crashes during such "updates" new autoinstaller/updater was written that can trace what sources you use: 'stable' or 'sarge'. Plesk for Debian repositories were moved to other location new autoinstaller/updater builds take updates from there. Previous locations were frozen to prevent old autoinstaller versions work.

    So that if you need to update Plesk - please download fresh console autoinstaller from http://www.swsoft.com/en/download/plesk/products/ and update with it. After you update and GUI updater is also renewed, you can continue using GUI updater for further updates.

    Thanks.
    Plesk Linux/Unix Support
    SWsoft
     
Loading...