1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Updater not updating

Discussion in 'Plesk for Linux - 8.x and Older' started by TXRanger, Aug 19, 2006.

  1. TXRanger

    TXRanger Guest

    0
     
    I am running Plesk 7.5.3 on Red Hat Enterprise Linux ES release 3 (Taroon Update 8). I started off with Plesk 7.0, but upgraded to 7.5.3 about a year ago. I decided to use the Plesk Updater to update to 7.5.4 to prepare for a future upgrade to Plesk 8. After solving a couple of minor dependency issues I finally got it to run without errors. However, it is still showing that it is running 7.5.3, and every time I run the updater for "Base packages of Plesk" under Plesk 7.5.4 Components the autoinstaller3.log shows "Installation done.
    Exit with OK status". But it still says I am running 7.5.3. I have gone through this several times, and even rebooted the server.

    Since I am not seeing anything obvious in the log file, how can I figure out what is keeping me from being updated to 7.5.4. Any ideas? Thanks!!
     
  2. geeza@

    geeza@ Basic Pleskian

    24
    23%
    Joined:
    Sep 1, 2005
    Messages:
    77
    Likes Received:
    0
    dude, always update using SSH not the updater in Plesk. That way you can see whats going on and its much less prone to causing problems.
     
  3. TXRanger

    TXRanger Guest

    0
     
    Thanks for the tip. I ran the /usr/local/psa/admin/bin/autoinstaller from bash via SSH, which I believe is what you suggested. The 2 required packages were "Base packages of Plesk" and "Plesk migration manager". Upon completion, I still got the same result saying that the upgrade to 7.5.4 was done, but the version is 7.5.3. The final screen gave me:
    Code:
    
    Preparing system for Plesk installation
    ===============================================================================
    
    There are 0 standard packages, that are necessary for Plesk and which
    were not found in your system.
    
    There are 0 standard packages, that are installed, but will be upgraded
    for product installation.
    
    
    
    N) Install Plesk and all required packages; P) Go back;
    Q) Cancel installing; L) Show list of packages;
    Select action [N]:
    Get Plesk product packages.
    Get system update packages.
    Start packages installation
    Installation done.
    
    It still says I am at 7.5.3, so something is not working.

    Any other ideas?
     
Loading...