• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

PleskDBException: Unable to connect to database

Pavel12

New Pleskian
PleskDBException: Unable to connect to database: mysql_connect(): No such file or directory (Error code: 2002) (Abstract.php:69)

Freshly installed distrib Ubuntu 14.04 / Plesk 12.
Everything worked out of the box,
When i tried to enable bind9 it failed
I did this:
http://kb.odin.com/en/120026
or wiped apparmor.

Now plesk is down due to db issues.
Mysql stopped
trying to restart - fails.

Any help appreciated

Thanks!
 
Try to use string "Unable to connect to database: mysql_connect(): No such file or directory" for search in KB articles.
There are many related articles. I hope it will help you find a reason and fix it.
 
If mysql itself will not start, then this wouldn't be a Plesk issue. What errors do you get when you try to start mysql?
 
Back
Top