1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Possible 4.0 Bug or 3 -> 4 Upgrade Bug?

Discussion in 'Sitebuilder 4.0 for Linux' started by zero@, Sep 3, 2007.

  1. zero@

    zero@ Guest

    0
     
    I recently upgraded Sitebuilder from 3 to 4, and I experienced some problems.

    First, I upgraded sitebuilder, but I didn't change my sources.list file, so while I partially upgraded, I was left with only about 10 sitebuilder templates and my own custom templates. So I figured out the problem, changed my sources.list file, and upgraded and downloaded all of the new templates. Problem solved.

    Only it wasn't. One of my clients was getting this error:

    Internal SiteBuilder error.
    File: /opt/sitebuilder/include/Zend/Zend/Db/Adapter/Abstract.php; Line: 156
    Message: SQLSTATE[HY093]: Invalid parameter number: no parameters were bound; Code: HY093

    Looks pretty serious. I looked all over for a solution, and I didn't find one, other than a bug in the mysql PDO driver. So I kept playing around with it - I reconfigured sitebuilder a few times, and fiddled with some settings, but still anytime this client would make a change, change a template, or try to publish they would get the error.

    Then I tried some other clients, and their sites were seemingly fine. I could make changes, publish the sites, upload pictures, etc.

    Then I tried changing the name of the site. Previously it was something like "Captain Jumpy's Shrimp Shack" (not the actual name), and so I changed it to "Captain Jumpys Shrimp Shack" - without the apostrophe between "y" and "s".

    And then it worked. :confused:

    Now I'm not sure if it was changing the name of the site, taking out the apostrophe, or if it was reloading my apache config. But it worked. At least for now.

    Hopefully someone can shed some light on this, or maybe this will help someone else.
     
  2. SibProgrammer

    SibProgrammer Regular Pleskian Staff Member

    29
     
    Joined:
    Nov 21, 2004
    Messages:
    342
    Likes Received:
    15
    I was unable to reproduce the bug and never seen such bug in our issue tracking system. If you got the error again, try to contact the support, cause such bugs requires a lot of investigations and access to the server.
     
  3. zero@

    zero@ Guest

    0
     
    Sorry I don't have more details. I'm on Debian Sarge. I upgraded from Plesk 8.1.2 (???) to 8.2. First I upgraded the base Plesk packages, and then I upgraded the other packages. I did not change my sources.list file initially, so the SiteBuilder upgrade was incomplete.

    I did manually edit the database tables to remove some templates before I figured out that the SB upgrade was incomplete. I might have done this incorrectly.

    Again, sorry I don't have more. If I experience more problems I'll open a support ticket.
     
  4. advwebsys

    advwebsys Guest

    0
     
    This just happened to me. I issued a support ticket and then decided to come here and search on publish settings.

    As it turns out it's the apostrophe!!!

    What's happening is the code is doing something like:

    insert into [table] set title='$title',name='$name'.....

    If $title has an ' in it you get:

    insert into [table] set title='Sammy's Print Shop',name='$name'.....

    which fails miserably.

    What's surprising is that the code doesn't 'scrub' data for ' and " replacing them with \' and \". I don't know about php, but perl actually has a function that does this for you.

    Fixed in 4.1 and/or 4.2?????
     
  5. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    David,

    This thread is replied in ticket which was created from your side. As a resume here I am outputting latest reply: Actually issues with apostrophe were caused by bugs in PHP and Zend Framework. Code sanitizing is actually performed, the issue with apostrophe and other symbols will be addressed in one of the future Sitebuilder updates.

    Let me know if there are still some questions/concerns left.
     
Loading...