1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem migrating

Discussion in 'Plesk for Windows - 8.x and Older' started by webdrv07, Sep 18, 2006.

  1. webdrv07

    webdrv07 Guest

    0
     
    Hello,

    Having a problem using the latest migration utility, and I can't find what the issue is. Wonder if anyone can help :)

    The agent is installed and running on the source server. (Winodws 2003 plesk 7 but has the same version PMM as the new plesk 7.6 server)

    The manager is installed and running on the destination host. (Windows 2003 Enterprise Plesk 7.6)

    The archives do get created on the source server and they do get downloaded to the PMM\source directory on the destination host, I see the .tgz files that have downloaded, they do not however get restored as accounts on the server.

    The migration wizard appears to fully complete, no errors are displayed and I see the message migration completed. When I check, the migrated domain does not exist on the server at all, no IIS config, no files are restored.

    This is the PMM log for the latest one I tried

    ----------------------------Exception_handled--------------------------------
    psaobsolete.PSADatabaseQueryException: Syntax error in UPDATE statement.
    at psaobsolete.PSAMySQLDatabase.execute(String queryStr)
    at Restore76Exp.InplaceRestoreEngine.checkDomainAppPool()
    at Restore76Exp.InplaceRestoreEngine.AddDomain(ObjectMigrationStage stage, domain param)
    ------------------------------------------------------------------------------
    Debug 09/18/2006 23:21:04 : InplaceRestoreEngine.AddDomain domain.co.nz failed (returns false)
    Debug 09/18/2006 23:21:04 : !!!! Rollback Transaction. !!!!
    Debug 09/18/2006 23:21:04 : InplaceRestoreEngine::RollbackTransaction
    Warning 09/18/2006 23:21:04 : Exception ignored: ( System.NullReferenceException: Object reference not set to an instance of an object. at Restore76Exp.RestoreStructure.ProcessDomain(Object obj, ReadStage stage) ) ( Object reference not set to an instance of an object. )
    Debug 09/18/2006 23:21:04 : Domains successfully migrated to the client mydomains

    It appears that there was an exception and this 'rolled back the transaction' thus the account does not exist on the server :(

    Does this help with debugging ? I really need to get this to work today, as I have 200+ domains to add to a new server from a server running plesk 7.0 ..

    Is it possible to restore the .tgz files somehow, manually from command line if the Plesk migrator is broken?

    Many thanks for amy pointers, fixes or advice :)
     
  2. webdrv07

    webdrv07 Guest

    0
     
    Still get the same error for every IIS domain account move, email accounts seem to transfer using the mail migration option, but the sites and users do not get copied over.

    The pleskdumps and tar files all appear on the destination system, they just don't get recreated as domains in plesk :(
     
  3. Dmitry Drozdov

    Dmitry Drozdov Guest

    0
     
    Hello,
    You should check Plesk License and disk space. Try to migrate by one domain.
    We have not released Plesk2Plesk Agent yet, for more detail/full migration you should use Plesk backup/restore tools.
    Thanks.
     
  4. Dmitry Drozdov

    Dmitry Drozdov Guest

    0
     
    Hello,
    It was a bug. We will fix it in the next release. Now you can avoid it. You should change some Plesk settings and restore migration content to Plesk again.
    1) Goto Plesk->Server Administration page -> IIS Application Pool -> Global Settings. You should select «Place domains in a shared application pool by default and allow use of dedicated pools for selected clients » and press “Okâ€.
    2) You should restart restore process. (You must have the migration dump.)
    For migration to existing client: start-> run -> and type “%plesk_dir%/admin/bin/migrmng.exe†--restore --use-client=<ClientLogin>
    Were ClientLogin is the existing Plesk’s Client login.
    For migration to default client: start-> run -> and type “%plesk_dir%/admin/bin/migrmng.exe†–restore
    If you don’t have the migration dump you should do 1) and migrate again.
    Thanks.
     
Loading...