1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

problem receiving email not hosted on plesk

Discussion in 'Plesk for Linux - 8.x and Older' started by ahcomput, Jan 26, 2006.

  1. ahcomput

    ahcomput Guest

    0
     
    Using Plesk 7.54

    I have a domain whose content is hosted on the Plesk server but the email is routed to an exchange server.

    I am finding that email's generated by Plesk are not routed to the recipient when there website is hosted on the Plesk box and email is hosted elsewhere. I'm not using the Plesk box for dns, rather using other external dns servers. I suspect plesk is seeing the domain on the server and stopping there rather than forwarding along to the external email address.

    Any help on resolving this is appreciated.

    -Ben
     
  2. vivhost

    vivhost Guest

    0
     
    Your MX record is wrong. Check your DNS settings for the domain you're hosting, the MX records should point to the external mail server.
     
  3. aviscat

    aviscat Guest

    0
     
    I am having a similar problem I posted about yesterday. Can you tell me what you mean by external mail server?
     
  4. vivhost

    vivhost Guest

    0
     
    They're hosting email on an exchange server, not on plesk. Therefore the MX record has to have the correct IP for that server.
     
  5. ahcomput

    ahcomput Guest

    0
     
    Thanks for the reply, but the mx records are correct (at least on the name servers I am using for all of my sites and email).

    Also, all external mail flow (outside) of the plesk box is working.

    I am not using plesk to dns and I believe it is disabled on the plesk box.
     
  6. vivhost

    vivhost Guest

    0
     
    OK, so you need to verify that the plesk box is resolving the MX record correctly. Look up the dig command and run in it in a shell to check the MX for that domain. If that checks out correctly, then it's not a DNS-related issue.
     
  7. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
  8. vivhost

    vivhost Guest

    0
     
    Yes, except the plesk box might do the lookup on its own named service where any of the records may be overridden. Trust me, a dig command is very useful.
     
  9. Smokester

    Smokester Guest

    0
     
    You need to remove the domain from the Qmail control files. Last I saw, turning off mail and DNS in Plesk didn't actually change the fact Plesk expected mail to be delivered locally. /var/qmail/control is where those files are located. Check to see if the domains are still listed in there, and if so, remove them and restart Qmail.
     
  10. vivhost

    vivhost Guest

    0
     
    That's correct...furthermore Plesk won't put the domain in Qmail control if the MX record is external AND you DISABLED MAIL (!) in the domain settings.
     
  11. ahcomput

    ahcomput Guest

    0
     
    Thanks all of you for your suggestions. Once I disabled mail for the domain, correct mail flow resumed to my external mail servers. I incorrectly assumed because the dns was being done externally, Plesk would follow that mx record to route mail. After reading your posts, I looked further for the mail service in the control panel and disabled it.

    Thanks Again.
     
  12. themancan@

    themancan@ Guest

    0
     
    Wow, I've been dealing with this issue for months on and off and the solution is as simple as disabling mail for the domain!

    Thanks for that. Kind of irritating that that overrides all the DNS.
     
Loading...