1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem with hostname

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by ZbyszekL, Nov 7, 2010.

  1. ZbyszekL

    ZbyszekL Basic Pleskian

    17
    85%
    Joined:
    Nov 7, 2010
    Messages:
    41
    Likes Received:
    0
    I'm using Plesk Control Panel 10

    When I log in to the panel by using the ip address which is https://xxx.xxx.xxx.xxx:8443/ then I can login, but when I type https://mydomain.com:8443/ I have a problem, and my browser get the message that can not open the page or connection timeout ...
    mydomain.com is set as the host name in plesk panel.

    After logging in to the panel, for example, when I click on the "service plans" then browser automatically changeing the link from the ip address to host address like:

    https://www.danter.com:8443/plesk-b...tps://92.43.112.13:8443&context=billing-plans

    and the connection timeout.

    Please help.

    Linux server Ubuntu 10.04 LTS
     
  2. WillemK

    WillemK Guest

    0
     
    You have two issues here

    1) you have not setup the domain www.danter.com actually resolve to your server. That is why your server is only accessible via IP. You either need setup the domain via the plesk panel, or via an external nameserver

    2) You have installed business manager, which automatically enables sso (single sign on) so you only have to log on once.

    As you noticed, the sso redirects you to a url based on the hostname set in the panel, instead of the beginning part of the url you used to access the server.

    You need to set the hostname of the server to something that does resolve to your ip address. You can check with on http://www.dnsqueries.com/en/ with reverse dns if your host has already set a domain name up for this. after this you can add the domain danter.com to plesk, and change the hostname back

    If you can no longer login to the admin panel because of sso you can disable it by logging in via ssh, and executing '/usr/local/psa/bin/sso --disable' Don't forget to re-enable it again after you fixed it
     
  3. ZbyszekL

    ZbyszekL Basic Pleskian

    17
    85%
    Joined:
    Nov 7, 2010
    Messages:
    41
    Likes Received:
    0
    I changed hostname and setup dns. Now I can login using ip or my hostname but...


    I can login by link https://myhost.pl:8443/ or https://my-ip-adress:8443/

    my sso config is:

    sudo /usr/local/psa/bin/sso -g
    SSO on
    sso server url: https://myhost.pl:11443
    sso relay url: https://myhost.pl:11444

    with sso enabled after login with link
    https://myhost.pl:8443/ link change to https://myhost.pl:11444/relay
    and after 20 sec link change to https://myhost.pl:8443/sso/ui
    with info: "Error: Element not found" above login form.

    with sso disabled I can login to plesk but still have errors in plesk-billing links:
    https://www.danter.pl:8443/plesk-bi...tps://myhost.pl:8443&context=billing-settings
     
Loading...