1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem with Migration Manager (Collations)

Discussion in 'Plesk for Linux - 8.x and Older' started by unixlibre, Dec 10, 2006.

  1. unixlibre

    unixlibre Guest

    0
     
    Dear all,

    I've ran into problems while running the migration manager to migrate from FreeBSD4.9/Plesk7.5.2 to FreeBSD6.0/Plesk8.0. The migration manager complains with

    ERROR 1267 (HY000) at line 1: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='

    It seems that all databases were created with latin1.

    The knowledge base says that one must try setting character_set_connection and collation_connection to utf8, which is not entirelly true because collation_connection sould be set to utf8_general_ci.

    One way of setting this vars is with the init_connection parameter in my.cnf. The problem is that for admin users, this is not executed (for "security" reasons as stated in mysql docs), so putting this setting in my.cnf has no effect at all.

    Anyone of you has a workaround for this?

    Thank you in advance.
    Antonio
     
Loading...