1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

qmail/horde problems

Discussion in 'Plesk for Linux - 8.x and Older' started by kburrell3, Apr 27, 2005.

  1. kburrell3

    kburrell3 Guest

    0
     
    I recently had my server reimaged with fcore 2 with plesk 7.5. Since that time email has not worked. When trying to send a message through horde I get this error:

    When I try to send an email to my self from another email address or from outlook I receive this error:

    Any help to fix this would be appreciated. Feel free to ask for more info as I am not sure where to begin on this. I have scoured google for answers and came up with nothing. The onlything I have found so far that was close was in the FAQ's telling me to add 127.0.0.1/8 to my whitelist. It was already there I removed it, readded it and restarted the smtp and imap services to see if this would correct the error. As of now I have had no luck.
     
  2. defencer

    defencer Guest

    0
     
    Just check do you have a qmail plugin chkrcptto:

    $ ls -l /var/qmail/plugins/chkrcptto
    -r-sr-xr-x 1 root root 14540 Jan 30 06:47 /var/qmail/plugins/chkrcptto
     
  3. kburrell3

    kburrell3 Guest

    0
     
    -r-sr-xr-x 1 root root 14532 Jan 27 23:28 /var/qmail/plugins/chkrcptto

    yep it shows up.
     
  4. defencer

    defencer Guest

    0
     
    Try this command:

    ls -ld /var /var/qmail /var/qmail/plugins
    drwxr-xr-x 24 root root 4096 Jul 4 2004 /var
    drwxr-xr-x 10 root qmail 4096 Jan 30 06:47 /var/qmail
    drwxr-xr-x 2 root qmail 4096 Feb 2 14:52 /var/qmail/plugins
     
  5. kburrell3

    kburrell3 Guest

    0
     
    Here ya go

    ls -ld /var /var/qmail /var/qmail/plugins
    drwxr-xr-x 23 root root 4096 Apr 25 06:58 /var
    drwxr-xr-x 12 root qmail 127 Dec 10 11:30 /var/qmail
    drwxr-xr-x 2 root qmail 22 Feb 17 04:44 /var/qmail/plugins


    my file sizes are different thats all I see. Thanks for the help btw.
     
  6. defencer

    defencer Guest

    0
     
    It is very strange, that the sizes of your directories differ from mine.

    OK. Let's check the binary file "chkrcptto"

    Create a fake domain in plesk, for example fakedomain.com

    Then go to the mail preferences of this domain and set up the "Mail to nonexistent user" properties to the "Reject" value. Do not create any mailuser.

    Then go to the command line and execute these commands:

    # export SMTPRCPTTO=nosuchmailuser@fakedomain.com
    # /var/qmail/plugins/chkrcptto

    My output for the last command is:

    E550 sorry, no mailbox here by that name. (#5.7.17)
     
  7. kburrell3

    kburrell3 Guest

    0
     
    I got the same output.

    E550 sorry, no mailbox here by that name. (#5.7.17)
     
  8. BoXie

    BoXie Guest

    0
     
    You might also want to check your /etc/hosts file ...

    Does it say
    Code:
    127.0.0.1 localhost localhost.localdomain
    
    ?

    Because Horde will need that .. it uses SMTP from localhost .. so localhost should resolve correctly. (<hordedir>/config/horde.conf)
     
  9. defencer

    defencer Guest

    0
     
    I beleave, the problem is that qmail-smtpd cannot execute chkrcptto for some reason. We know, that chkrcptto works OK.

    BTW, why your direcories /var/qmail & /var/qmail/plugins have so strange size? Are they symlinks?
     
  10. BoXie

    BoXie Guest

    0
     
    Don't directories always show up with this size in an 'ls' command in Linux ?
     
  11. kburrell3

    kburrell3 Guest

    0
     
    I reimaged the server and email works now. However the folder sizes are still different. I was under the impression all folders should show 4096 who knows it works.
     
  12. VengfulSquirrel

    VengfulSquirrel Guest

    0
     
    Broken

    Hello Hello

    This is the only place I could really see chkrptto mentioned.

    Do you guys actually get output from it on stdout ?

    Because if I do
    # export SMTPRCPTTO=nosuchmailuser@fakedomain.com
    # /var/qmail/plugins/chkrcptto
    #

    So basically I get nothing out of the command... is it supposed to write to a file? Or is it just broken?

    Thanks
    -Ian
     
  13. bonesadams

    bonesadams Guest

    0
     
    This fixed it.

    I tried many things to fix it but only this helped:

    rpm -qa |grep qmail
    psa-qmail-1.03-fc4.build80060331.13
    psa-qmail-rblsmtpd-0.70-fc4.build80060613.20
    psa-qmail-1.03-fc4.build80060428.20
    psa-qmail-1.03-fc4.build80060613.20
    drweb-qmail-4.33-fc4.build80060613.20


    rpm --erase --nodeps psa-qmail-1.03-fc4.build80060331.13 psa-qmail-1.03-fc4.build80060428.20 psa-qmail-1.03-fc4.build80060613.20

    and then just install them again.


    rpm -Uvh /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-4-i386/base/psa-qmail-1.03-fc4.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-4-i386/base/psa-qmail-1.03-fc4.build80060428.20.i586.rpm /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-i386/base/psa-qmail-1.03-fc4.build80060613.20.i586.rpm

    Maybe there will be other builds but you got the picture. :)

    Hope this will help so.
     
Loading...