1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail just stops, almost daily!!!

Discussion in 'Plesk for Linux - 8.x and Older' started by Hal9000, Nov 15, 2005.

  1. Hal9000

    Hal9000 Guest

    0
     
    I have problems with Qmail (using Plesk 7.5.4 on Debian 3.1).
    It happens very often that Qmail just stops working! Under "Services" in the control panel it is stated as "not running", but the watchdog think it has been restarted and that it is up, but it's not!
    Reading this forum i saw many complaining about the watchdog actually being responsible for the Qmail problems. So i uninstalled it, but tonight it happened again! Qmail just stopped!
    I can't afford all these hours of mail server downtime, please help me to fix this problem :(

    Nov 15 00:08:53 localhost qmail: 1132009733.073060 delivery 4: deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)/
    Nov 15 00:08:53 localhost qmail: 1132009733.073098 status: local 0/10 remote 0/20 exitasap
    Nov 15 00:08:53 localhost qmail: 1132009733.073489 status: exiting

    These were the log messages when it appearantly stopped. 12 hours downtime! :( I wish i could go back to Postfix...

    hal
     
  2. hardweb

    hardweb Guest

    0
     
    There is indeed a problem in Debian with qmail, but I can tell you that no one on this forum can help you. Try to contact swsoft support regarding this problem.
     
  3. DaveNET@

    DaveNET@ Guest

    0
     
    Thanks for the heads up Hardweb. I had Qmail stop about 4 times in the last 2 hours. It stays down for 8 to 9 minutes each time. I will contact Psoft.

    David
     
  4. jinxedworld

    jinxedworld Guest

    0
     
    Does anyone have an update about this issue? I'm having the same problems on multiple Debian boxes. I already contacted SW Soft support (had to make a change in the qmail init file) but it doesn't seem to be sufficient.
     
  5. Hal9000

    Hal9000 Guest

    0
     
    could you please tell which change they told you to do?
     
  6. fercez

    fercez Guest

    0
     
    I have exactly the same problems, but with Plesk 7.5.4 on Fedora Core 2.

    Almost every day Qmail stops, I have disabled watchdog but problem becomes worst: Qmail stops more often. Right now I just disabled Watchdog for Qmail and it stops once daily

    Any ideas? :confused:

    Fernando
     
  7. jinxedworld

    jinxedworld Guest

    0
     
    I fixed it! I moved the TCPwrapper from inetd to tcpserver. Works like a charm! Need someone to do it for you on Debian? Just contact me on dennis [AT] brainstorm-ict [DOT] nl. I'm sure we can arrange something.
     
  8. Mitch@

    Mitch@ Guest

    0
     
    I have the same problem, I have Linux server and the Qmal stops automatically! Could you tell me how you fix it excatly, as I live in Egypt and its so hard to contact anybody. Only by this forum!
    Thanks
     
  9. tek01

    tek01 Guest

    0
     
    Same problem

    Linux Centos, Plesk 7.5.4 and Qmail stops automatically several times a day

    What to do ?

    How to switch to tcpserver ?
     
  10. Hal9000

    Hal9000 Guest

    0
     
    anyone has any solution for this problem?
    the watchdog doesn't always work properly, this is a very annoying situation...
    i hope plesk 7.5.5 will fix this problem!
     
  11. dl2rbi

    dl2rbi Guest

    0
     
    same qmail pronlem with suse 9.3

    I have the same problem on a new installed server.

    The log in /usr/local/psa/var/modules/watchdog/log has the following entry, which shows the source of the qmail problem:

    [CET Dec 23 02:18:20] SMTP: error receiving data -- Resource temporarily unavailable
    [CET Dec 23 02:18:20] 'qmail' failed protocol test [SMTP] at INET[localhost:25].
    [CET Dec 23 02:18:20] 'qmail' trying to restart
    [CET Dec 23 02:18:20] 'qmail' stop: /usr/local/psa/admin/bin/mailmng
    [CET Dec 23 02:18:20] 'qmail' start: /usr/local/psa/admin/bin/mailmng
    [CET Dec 23 02:43:22] 'qmail' connection passed

    The SMTP-protocol test failed ...

    After restarting the qmail service, all mails are handled properly.

    Any idea ?
     
  12. Cranky

    Cranky Guest

    0
     
    What builds of Plesk are you using?

    cat /usr/local/psa/version
     
  13. dl2rbi

    dl2rbi Guest

    0
     
    plesk version

    it should be the newest available (updated) version:
    content of version file: 7.5.4 SuSE 9.3 75051209.14
     
  14. Hal9000

    Hal9000 Guest

    0
     
    cat /opt/psa/version
    7.5.4 Debian 3.1 75051115.01
     
  15. NorthLANs

    NorthLANs Guest

    0
     
    I'm getting the same thing with Qmail stopping on its own.

    cat /usr/local/psa/version
    7.5.4 FedoraCore 3 75051209.14
     
  16. orangeguru

    orangeguru Guest

    0
     
    Same problem here.

    Plesk 7.5.4
    SuSE 9.3

    Does anyone have a fix?

    I would even settle for a chronjob that restarts qmail every 3 hours.

    Any shell geek out there?

    Thanks!
     
  17. Hal9000

    Hal9000 Guest

    0
     
    how long does it take for sw-soft to fix this? :(
    THIS SUCKS!!!
    the best solution would be to switch to postfix, but as long as we have qmail, it should work!
    i can't live with my mail server being that unstable, and the watchdog being unreliable! THIS HAS GOT TO STOP!
     
  18. Cranky

    Cranky Guest

    0
     
    Are you all running Watchdog to monitor qmail?
     
  19. orangeguru

    orangeguru Guest

    0
     
    Yep.
     
  20. Cranky

    Cranky Guest

    0
     
    Have you tried disabling the qmail check to see if it's watchdog which is killing qmail?
     
Loading...