1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail-send Program Error

Discussion in 'Plesk for Linux - 8.x and Older' started by jsktech, Jun 8, 2005.

  1. jsktech

    jsktech Guest

    0
     
    I a one domain that I know of that when I create a new email account it will not work it just keeps bouncing back the message with the following error. All of the existing email accounts for this domain work only new ones I create. Anyone have ideas what might be causing my problem?

    Hi. This is the qmail-send program at rh7319479.myserver.net.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <bob@domain.com>:
    Sorry. Although I'm listed as a best-preference MX or A for that host, it isn't in my control/locals file, so I don't treat it as local. (#5.4.6)
     
  2. hardweb

    hardweb Guest

    0
     
    Try to execute in shell the command:

    /usr/local/psa/admin/bin/mchk

    It should solve your issue.
     
  3. jsktech

    jsktech Guest

    0
     
    Should the command
    /usr/local/psa/admin/bin/mchk
    display any results or other kind of massage when it is complete? When I executed the command all I got was a new line, and did not seem to fix my problem. I also restart the mail services after running it.
     
  4. voodoochile

    voodoochile Guest

    0
     
    Go into the Mail settings for the domain in question, disable mail, then enable it. Sometimes that'll clean it up a bit.

    I had a simliar problem not long ago where I forgot to stop Plesk while doing a Perl upgrade, which caused a bit of corruption in the database. Enabling/Disabling mail for just that domain fixed it.
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Check your /var/qmail/control/rcpthosts file and make sure it has entries for all the domains you are hosting. And the /var/qmail/control/locals file should at least have 'localhost'.

    Then restart qmail.
     
  6. perlboy

    perlboy Guest

    0
     
    No, it will be backgrounded and return you to a prompt. To know WHEN it's actually finished try adding -vv to the end.

    Stuart
     
  7. jsktech

    jsktech Guest

    0
     
    After running mchk I disable mail and then enable it and that seemed to fix my problem.

    Thanks
     
Loading...