1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail SMTP crashes with "Permission Denied"

Discussion in 'Plesk for Linux - 8.x and Older' started by Teej, Apr 22, 2007.

  1. Teej

    Teej Guest

    0
     
    Fedora Core 5 / Plesk 8.1.0
    When attempting to deliver mail to qmail it fails with:
    Code:
    Connected to mail.domain.net.
    Escape character is '^]'.
    220 domain.net ESMTP
    EHLO test.net
    250-domain.net
    250-AUTH=LOGIN CRAM-MD5 PLAIN
    250-AUTH LOGIN CRAM-MD5 PLAIN
    250-STARTTLS
    250-PIPELINING
    250 8BITMIME
    mail from: [email]test@test.net[/email]
    250 ok
    rcpt to: [email]andrew@domain.net[/email]
    421 fopen('users/assign') failed (#5.7.10) Permission denied
    Connection closed by foreign host.
    
    After a lot of investigation I found that the file permissions for /var/qmail/users/assign were set to:
    Code:
    -rw------- 1 root qmail 2772 Apr 22 10:38 assign
    Changing them to allow group and all read access fixed the issue:
    Code:
    $ chmod 644 assign
    $ ls -l assign
    -rw-r--r-- 1 root qmail 2772 Apr 22 10:38 assign
    But any time I run the Plesk control panel Mail Add New Mail Name or Add New Mail Alias the permissions are reset and the fault returns.

    Is there a fix for this?
     
  2. youngnovice

    youngnovice Guest

    0
     
    421 fopen('users/assign')

    Having the same issue. Anyone have a fix. Did a qmail repair/reset permissions with spam. Problem still exists.

    Only a few domains are having issues with this others are sending and receiving fine. I even disabled mail for the problem domains and re-enabled mail, but still not working, deleted email address and re-added. Even tried changing the permission of the file "assign" to 644, but still no luck.

    Receiving the error when trying to send mail to the domains: 421 fopen('users/assign') failed (#5.7.10) Permission denied

    Also checkdns.net shows the error when doing the mail server test.

    My permission says the same exact as the first poster.

    Code:
    -rw------- 1 root qmail 2772 Apr 22 10:38 assign
    Looked at the assign file, but didn't see anything odd. As I mentioned only a few domains are having the users/assign permissions denied problem.

    Can someone please advise.
     
  3. simpliq_adi

    simpliq_adi Guest

    0
     
    Hello,

    Try to upgrade Plesk to 8.2 or 8.3 this should solve it.
     
  4. youngnovice

    youngnovice Guest

    0
     
    It was already upgraded some time ago.
     
  5. youngnovice

    youngnovice Guest

    0
     
    /users/assign permisson denied

    Sends fine when the permission is changed, but once an email address is added the permission resets itself. Anybody?
     
Loading...