1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail up but does not respond!

Discussion in 'Plesk for Linux - 8.x and Older' started by egs2009, Jun 8, 2005.

  1. egs2009

    egs2009 Guest

    0
     
    Hello,

    I'm wondering if anyone has had this problem. I can receive mail but I can't send for some reason.

    Qmail is running and I can connect to it but it won't accept any commands or input it just seems dead but it gives the 220 greeting message.

    I have already force reinstalled the RPM for Plesk qmail but it still isn't working there was also a /usr/local/psa/admin/sbin/mchk -v command and that didn't work.

    If anyone has an idea of how to fix this it would be appreciated :)

    Thanks
     
  2. webjfg

    webjfg Basic Pleskian

    24
    40%
    Joined:
    Jun 8, 2005
    Messages:
    39
    Likes Received:
    0
    i have the same problem with my server
    Plesk 7.5.3 with fedora core 2
     
  3. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Have you checked the maillog for any indications? /usr/local/psa/admin/logs/maillog

    Or the messages log (/var/log/messages)?

    Was this a fresh install, or upgrade (from what earlier version of Plesk?)

    Does the control panel show it as running, and have you tried restarting it from the control panel?

    Sorry if these are basic questions, but you didn't mention anything in your post, so I thought I'd just ask.

    Another thread related to Qmail problems:

    http://forum.plesk.com/showthread.php?threadid=16723&highlight=mchk

    basically, forcing a reinstall of the psa-qmail fixed some other's problems.
     
  4. egs2009

    egs2009 Guest

    0
     
    No change to Plesk was actually made but I did an apt-get -f and it installed about 34 new packages and I cannot find a log of it and I don't think apt-get kept one :(

    I have forced reinstalled the Plesk qmail RPM and I have also removed and reinstalled the DrWeb RPMs and restarted Plesk with no luck.

    I can't successfully even connect to the mail server through SMTP (POP works). It just hangs even though it gives the initial 220 response:

    Connected to mail.bla.com (ip).
    Escape character is '^]'.
    220 hostname.com ESMTP

    The logs don't turn up anything useful except maillog has a 4.4.1 error that it cannot connect to an SMTP server but no errors related to logging in to the SMTP server which I can't do.

    I should note sending through webmail is fine but that uses IMAP of course....

    Thanks for your help guys keep the ideas coming :)
     
  5. webjfg

    webjfg Basic Pleskian

    24
    40%
    Joined:
    Jun 8, 2005
    Messages:
    39
    Likes Received:
    0
    i have check this. if from my box i telnet (telnet localhost 25) qmail respond. if i try from the outside the server is not responding.. i thing it's a firewall problem. i have check the firewall setting in plesk and everithing seam to be fine. i have check if the firewall get up in my messages log when i reboot.. and on 1 line it say no .. and after it say succesfull start.

    i have try to restart the service (/sbin/service psa-firewall start) and i receive psa-firewall: service is disabled
     
  6. egs2009

    egs2009 Guest

    0
     
    Mine is not a firewall issue because I can connect from the outside.

    I still have no idea how to resolve this.

    Does anyone have an idea?
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    This may seem silly, but check the /etc/hosts file, make sure the first line
    127.0.0.1 localhost.localdomain localhost
    does not contain your server's name.

    Then put a second line:
    <server IP> xyz.domain.tld (like ns.domain.com or mail.domain.com whatever your hostname is)

    Restart server.

    If you hae qmHandle, you could also do a qmHandle -a to force processing of the queue.

    No offense intended (remember months from now a newbie will look at this), but I had to fix another server recently where they had put
    127.0.0.1 localhost.localdomain localhost xyz.domain.tld

    and messages were stacking up in the queue with nowhere to go. Their qmail was running, accepting messages, but never delivering to the user mailboxes. Also would get hung response from telnet to port 25.
     
  8. egs2009

    egs2009 Guest

    0
     
    No offense taken, especially if a an offensive sounding tip solves the issue :)

    I don't think that was the issue although there were multiple entries on one line I have removed them and restarted without any change.

    I can see the SMTP welcome message but can't actually login to it.

    Although incoming mail works fine I should mention that changing a password in Plesk has no effect (it doesn't actually change).

    I'm worried Plesk/Qmail is totally hooped :(
     
  9. egs2009

    egs2009 Guest

    0
     
    Whenever I connect to the mail server here is what I get the welcome message and typing any command like "user name@domain.com" results in

    502 unimplemented (#5.5.1)

    Any ideas?
     
  10. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, that's not a good sign either.

    Just for giggles, see if there are any errors of importance in the /var/log/mysqld.log file
     
  11. egs2009

    egs2009 Guest

    0
     
    It doesn't seem totally broken though:

    helo
    250 ns1.*
    mail to: somename@place.com
    250 ok
    rcpt to: othername@jfdk.com
    553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)


    I see no errors in MySQL

    Keep in mind I can receive through POP and I can send/receive fine through IMAP.

    I have tried every possible thing I can think of :(

    Thanks again for the help though :)
     
  12. jamesyeeoc

    jamesyeeoc Guest

    0
     
    (Edit: I know this is not going to be the problem, but due to the error you posted, we should check it anyways...besides, the bed is beckoning me...but the caffeine is resisting...lol)

    Ok, what is the content of the /var/qmail/control/rcpthosts file?

    This should have all of your hosted domain.com names in it, one per line.

    Assuming the HELO greeting is your actual server, I was able to telnet to it and when I specified rcpt to: aaa@yourdomain.com it accepted it fine.

    So definitely check the rcpthosts file to ensure it has all your hosted domains listed.

    I guess we're making some progress, your first post said the telnet went dead/hung after initial greeting, now it's at least responding to commands.

    What are the contents of the other control files in /var/qmail/control?

    The password not changing issue is what needs to be looked at, signs of a bigger problem...
     
  13. egs2009

    egs2009 Guest

    0
     
    rcpthosts is looking good too :)
     
  14. egs2009

    egs2009 Guest

    0
     
    Anyone have any words of wisdom? At this time I can change a password of an e-mail account from the control panel but I cannot receive or send mail except through webmail IMAP.

    I think some mail server or related xinetd options have been changed somehow.

    Can someone with a working Plesk paste the contents of /etc/xinetd.d/ipop3 ?

    Now when trying to authenticate I get a bad password and I think maybe it's trying to check the wrong password db or using the wrong program.

    Thanks (any other suggestions are welcomed)

    My current contents of ipop3 are:

    service pop3
    {
    disable = no
    socket_type = stream
    wait = no
    user = root
    server = /usr/sbin/ipop3d
    log_on_success += HOST DURATION
    log_on_failure += HOST
    }
     
  15. jamesyeeoc

    jamesyeeoc Guest

    0
     
    My RH boxes on 7.5.3 don't have the file:

    /etc/xinetd.d/ipop3
     
  16. tmonsen

    tmonsen Guest

    0
     
    I also don't have the file on FC2/7.53
     
  17. jamesyeeoc

    jamesyeeoc Guest

    0
     
    egs2009 - please give us history about your server. Other than the default Plesk install and Server updater, what other software or mods have been done to the server?? Even if something seems to be trivial to you, for us to assist you *effectively*, we do need background history on a server...
     
  18. egs2009

    egs2009 Guest

    0
     
    Any idea exactly what program/services and config files are involved in the mail check process?

    I have forced removed and reinstalled all DrWeb, SPAM and Qmail, courier-imap related RPMs without any luck :(

    I can tell it is checking for a password but likely in the wrong location, wrong database etc because the correct pw is always rejected as bad
     
  19. egs2009

    egs2009 Guest

    0
     
    It is PSA 7.5.2 RH 7.3
    All I can remember that would be helpful in solving the problem is that one day after running an apt-get which updated a bunch of packages I did not intend for it to that mail was broken.

    Unfortunately I don't have a log or list of what it did :(
     
  20. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The real question is where did the ipop3 come from?
    If you didn't have it installed from the RH7 distro before, then maybe the apt-get installed it.

    I have asked before but not gotten response: what OS are you using?

    [Edit: Nevermind about OS....]

    Oops, I guess we cross posted...

    RH includes a default pop3 (uw-imap) and if that got installed, then it probably replaced the normal courier-imap which Plesk uses.
     
Loading...