1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Question about Log Rotation

Discussion in 'Plesk for Linux - 8.x and Older' started by CruzioT, Apr 8, 2011.

  1. CruzioT

    CruzioT Guest

    0
     
    Hello

    One of our servers is running Plesk 8.2. We have a customer who is generating a lot of errors due to a problem with their Joomla installation. Because it is taking them some time to try to fix the problem, they are generating large error log files.

    In Plesk, I have set their log rotation to limit the log files to 128k. However they still end up with log files in Gigabyte size. Now I realize the true problem is their Joomla installation which is generating the errors. However, I am wondering how the log rotation works since the log files can easily go well over the limit placed in the rotation settings.

    Is this a configuration issue? Or is it just the nature of how the rotation works? Perhaps the rotation only checks on a regular interval, and if too many errors occur between that interval nothing can be done?

    I also understand that the Report section on Plesk only updates every 24 hours, so it's very common for a disk over quota error to be reported despite it having gone under quota long ago. Is this something configurable?

    Are any of these issues addressed in later versions of Plesk?

    I am not our server administrator and thus am not intimately familiar with Plesk, however I wanted to try inquiring before bothering the engineers who have their hands pretty full. Any advice, or pointing in the right direction is greatly appreciated, thank you.
     
  2. shall

    shall Regular Pleskian

    26
    57%
    Joined:
    Apr 2, 2007
    Messages:
    226
    Likes Received:
    0
    I know this is months old, but the answer might help others.

    The issue you're facing is that the log is checked for size only once per day, thus the 'size' limit you've created isn't going to work the way you're trying.
     
Loading...