1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

quotacheck cannot stat vhosts/domain.ext/dev/null permission denied

Discussion in 'Plesk 11.x for Linux' started by Schokkie, Aug 15, 2012.

  1. Schokkie

    Schokkie New Pleskian

    13
    60%
    Joined:
    Jun 2, 2011
    Messages:
    20
    Likes Received:
    0
    I'm trying to add quota to a fresh Plesk 11.0.9 server on CentOS 6.3.
    If i do quotacheck -avugm it exits on an error saying:

    quotacheck: lstat Cannot stat `//home/httpd/vhosts/chroot/dev/null': Permission denied
    Guess you'd better run fsck first !
    exiting...

    I've tried removing that file (i can re-add it using mknod) but a lot of vhosts also have this file.
    Removing and re-adding all /dev/null files helps and quota's are on but another quotacheck will result in the same error.
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Plesk automatically installs these quotas, why are you doing it manually?

    BTW: what are you results for

    # grep HTTPD_VHOSTS_D /etc/psa/psa.conf
     
    Last edited: Aug 15, 2012
  3. Schokkie

    Schokkie New Pleskian

    13
    60%
    Joined:
    Jun 2, 2011
    Messages:
    20
    Likes Received:
    0
    That would be:
    HTTPD_VHOSTS_D /home/httpd/vhosts

    Plesk does not seem to install this as the option for hard disk quotas was greyed out saying quotas wheren't supported by the file system configuration. I had to do this manually.
     
Loading...