1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Restoring original directory permissions

Discussion in 'Plesk for Linux - 8.x and Older' started by ideawire_bb, Mar 15, 2005.

  1. ideawire_bb

    ideawire_bb Guest

    0
     
    I ran a script in a domain and hosed the permissions on that directory and a few levels above. Is there a utility that exists that will restore permissions on the directory?

    I can't just re-create the domain since a large number of mail accounts exist and recreation will be a hassle.

    Any help will be appreciated.
     
  2. keith_h

    keith_h Guest

    0
     
    Right there with you brother. I have hosed the /usr/local/psa and everthing under it. Anyone got a script to restore it??

    TIA
     
  3. ideawire_bb

    ideawire_bb Guest

    0
     
    I had the joy of manually restoring /home/httpd/vhost/... for all the system domains.

    Be careful with root kids.

    There should be some sort of script that checks the permissions recursively and corrects them if wrong. This would likely solve a number of errors that come up as a result of incorrect permissions.
     
  4. keith_h

    keith_h Guest

    0
     
    I eventually got it working agaon chmod -R 4777 /usr/local/usr/ *

    Not ideal but it worked.
     
Loading...