1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

RSS feed working in preview but not when published

Discussion in 'SiteBuilder' started by burnley, Jun 14, 2009.

  1. burnley

    burnley Regular Pleskian

    28
    57%
    Joined:
    Feb 6, 2008
    Messages:
    222
    Likes Received:
    2
    Location:
    Melbourne, Vic
    Greetings all,

    We recently had a client install the RSS feed onto their site using the module in Sitebuilder. They selected on of the pre-configured feeds and previewed their site and everything looked fine. However when the client published the site they get the following error:

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /var/www/vhosts/<domain>/httpdocs/include/SB/Modules/HttpRequest.php on line 178

    Firstly we went and checked that PHP is enabled for their site and that safe mode was off, no issues there. Now we can resolve this issue by manually adding the relevant path to the open_basedir parameters in the vhost.conf file for the domain, rebuilding and restating Apache.

    Basically my question is why do we need to do this, shouldn't this sort of thing be configured into Sitebuilder? Is there a work-around or fix for this something we are missing something? I can't believe everyone has to add an exception each time a client wishes to use an RSS feed on their site.

    We are running Sitebuilder 4.5.6 on Plesk 8.3

    Regards,

    Chris
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    This is related to PHP curl function. Please check following note: http://php.net/manual/en/function.curl-setopt.php#71313

    The thing is that some of the channels added into RSS module by default may not exist anymore and have redirection to some other places. It is not possible to trace all the changes which are done on each RSS channel. So when such redirection takes place it uses CURL and at the end you get the warning (which is explained on php.net site). There are two ways for resolving this case:

    1. Modify php.ini (in your case this should be /etc/php.ini ) so no warning messages are displayed - this is a common practice, after all. Just disable warnings output (display_errors = Off, also make sure that 'error_reporting' is commented). After that do not forget to restart apache service.

    2. Check RSS channels list here: /usr/local/sitebuilder/include/Modules/RssReader/Settings/channels_list.xml and make sure that all links work fine without any redirections.
    As soon as it's done, re-publish the site and check it one more time. Try this.
     
Loading...