1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

securing qmail for open relay

Discussion in 'Plesk for Linux - 8.x and Older' started by ebudihar, Sep 11, 2008.

  1. ebudihar

    ebudihar New Pleskian

    22
     
    Joined:
    Sep 11, 2008
    Messages:
    2
    Likes Received:
    0
    Right now,
    I am looking for a way how to secure qmail from open relay and still sending and receiving without someone use my mail server to send any spams emails. What I have in the plesk 8.6 is just server>Mail>Relaying (closed, authorization is required: POP3 or SMTP). When I choose "closed", the mail server is totally closed relay and I cannot send any emails and sometimes I cannot receive emails. But if I choose the other, my email server will be open relay and someone can use it to send spams.

    Do you mind if you can tell me how to secure the qmail to closed relay and I can still sending and receiving emails.

    I am looking forward to a favorable reply from you. Thank you.


    Regards,
    Eko
     
  2. faris

    faris Guest

    0
     
    Hi Eko,

    You would normally have it set to "authorization is required", with only the SMTP tick box ticked.

    This will NOT stop any email from being send to an email address that is configured in Plesk on your server.

    It WILL stop spammers using your server as an open relay, as the only way to send email to addresses not on your server is by using SMTP authentication.

    In your email program, you would need to configure a setting that looks something like "My outgoing (SMTP) server requires authentication", and you would need to give the email program the correct username and password for this authentication. These are exactly the same as for recieving email -- i.e. the FULL email address and password.

    You may run into problems with authentication if you have Outlook 2007 or a Mac. In both cases there will be problems if you have put a tick in POP3 as well as SMTP box under "authorization is required" in Plesk, or have added the IP address of your internet connection in the White List section. In addition, if the IP address of your internet connection is blacklisted (which it might well be if you use, for example, zen.spamhaus.org in your DNS blackhole list, your connection attempt may also be prevented. You can get around this latter problem by enabling the "submission" port (587) in Plesk 8.3 (I think) and later, or by manually adding it.

    I hope some of this helps. If not then maybe the problem you are having when enabling authentication is not quite what it seems, or I have misunderstood your problem.

    Remember, enter the FULL email address as the username, not just the part before the @ when setting up your email program. Although Plesk does have a setting that allows you to just use the part before the @, it is best to use the whole thing.

    Faris.
     
Loading...