1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Several Sitebuilder Issues and Questions

Discussion in 'Sitebuilder 3.0 for Linux' started by npregean, May 16, 2007.

  1. npregean

    npregean Guest

    0
     
    1) Firstly I want to ask how exactly Plesk and Sitebuilder integrate together. I want Plesk to create a new domain and Sitebuilder accesses that domain and automatically publishes a site. I don't want the user to have to enter in any publishing information, it should all happen behind the scenes. This is what I define as integration between the applications...is this possible? Can I have Sitebuilder automatically publish websites to Plesk domains that are created? If so, how is this possible?

    2) Publishing issues - I seem to be able to publish to my server fine if I use XCopy, but FTP plainly does not work. I've tried all sorts of ways to get around this. Before you ask, yes, I've used the "check.php" and confirmed that everything passes in the FTP location. The FTP location is on the same server as Sitebuilder by the way in one of my domains created in Plesk.

    3) Blog module - For some reason my Blog module will not work properly with XCopy. It says "published but with some errors."

    The error logs report:

    Modules 5/16/2007 2:28:48 PM npregean120 68.11.94.173 The data of 'Blogger' module (id is '8k3ru6wntt8') was published successfully (site alias is 'npregean120', owner is 'npregean120').
    Modules 5/16/2007 2:28:48 PM npregean120 68.11.94.173 The data of 'ImageGallery' module (id is 'awgrv1yy8ou') was published successfully (site alias is 'npregean120', owner is 'npregean120').
    Modules 5/16/2007 2:28:47 PM npregean120 68.11.94.173 The data of 'ImageGallery' module (id is 'urvz10nkbop') was published successfully (site alias is 'npregean120', owner is 'npregean120').
    Modules 5/16/2007 2:28:47 PM npregean120 68.11.94.173 Empty database for 'Blogger' module (id is '8k3ru6wntt8') has been created (site alias is 'npregean120', owner is 'npregean120').
    Modules 5/16/2007 2:28:46 PM npregean120 68.11.94.173 Cannot find data of 'Blogger' module (id is '8k3ru6wntt8', site alias is 'npregean120', owner is 'npregean120'). All module data has been lost.
    Modules 5/16/2007 2:28:35 PM npregean120 68.11.94.173 Cannot create database for 'Blog' module (current site is 'npregean120')

    Then when I go to edit it, I get this message: "The XCopy published site is not accessible now." Image Gallery works fine.

    Anyone have any thoughts? I called up SWSoft and they said none of their developers would be available until 10PM tonight...I'm guessing because they're on the other side of the world outsourced. :(
     
  2. npregean

    npregean Guest

    0
     
    Ok, I've resolved this for the most part. It seems like my publishing problems arose from my server provider enabling safe mode in my php.ini file.

    If you're having publishing issues, my advice is to make that in your server php.ini file, that it says "Safe Mode = Off."

    I'm still waiting for an answer on my first question, but I'm guessing it's not possible. It seems like I'm going to have to find a programmer that can develop a PHP script for Plesk integration...you'd think something like this would be included in "integration" honestly.
     
  3. npregean

    npregean Guest

    0
     
    I've spent a good bit of money so far with your company, and I'm really starting to lose my patience...a simple yes or no to the question would do.
     
  4. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Plesk and Sitebuilder are integrated through SBM module and if it is installed on your server it should be available in Plesk admin CP -> Modules -> Remote Administrator module for Sitebuilder 3.

    There you need first enable domain in Resellers tab and after that in Domains tab. This actions will create custom button for domain and user could access Sitebuilder wizard through this custom button but for publication settings required. User should configure settings only once and after that it will be saved and there won't be necessary to type them again.
    For more information about integration module you can check 'Sitebuilder Remote Administration Module v3.0: Administrator's Guide': http://www.swsoft.com/en/products/plesk/docs/

     
  5. npregean

    npregean Guest

    0
     
    Thanks for your response..I have a very specialized way in which I need to integrate Sitebuilder and Plesk.

    Essentially my clients that buy sites in Sitebuilder are not going to have access to a Plesk account to manage so they won't see the "Sitebuilder" button. They are instead buying a website through an automatic process which will completely automate the entire process of publishing a website: choosing a domain name (through a domain reseller API), hosting is setup automatically based on the domain name they choose, and the site is published automatically to the hosting account in Plesk.

    So it goes like this:

    1) Customer Chooses domain.

    2) System Creates client,attaches domain in Plesk using physical hosting on a shared IP, and sets up FTP account for the domain.

    3) Create site in Sitebuilder using chosen domain and publish via FTP to the associated domain

    Based on your answer, I think I am going to have to use both the Plesk and Sitebuilder API to accomplish that. That is why I wanted to clarify integration because it does not seem Sitebuilder and Plesk are integrated in the way that I need them to use them and in the order that certain tasks need to be accomplished.
     
  6. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    For integration purposes you can use Sitebuilder API. Here you can find integration guide: http://download1.swsoft.com/SiteBui..._US/sitebulder-3.2-win-sdk-integration-guide/

    This guide was written for Sitebuilder for Windows but it can be also used for Sitebuilder for Linux. To be able to use API you need to make sure that sitebuilder_remote-admin-3.0.2 module is installed on your server.
    Hope this could help you.
     
Loading...