1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Sitebuilder install page

Discussion in 'Legacy Sitebuilder Software' started by harryg@, Jun 17, 2005.

  1. harryg@

    harryg@ Guest

    0
     
    Hi

    I am facing this curious problem.

    I have set up a number of virtual servers on my new server. Whenever anyone tries to visit the sitebuilder, it takes them instead to the sitebuilder install page.

    So a request for sitebuilder.xxx.com will take the visitors to sitebuilder.xxx.com/install/install.php instead.

    Further, even this install page does not work... it crashes with a complaint about being unable to build database tables.

    Any help would be much appreciated

    HarryG
     
  2. weschyrchel

    weschyrchel Guest

    0
     
    I am having the exact same problem. It seems to go away and come back. It's also starting to affect other programs that I am running on the server, such as Group-Office. Now I am getting the .../Install/install.php redirect from there as well. I raised my memory limit to 20M in my php.ini and that seemed to help it briefly, and then it came back again. I have emailed support so we should see what is going to happen. If I hear anything I will update the case.
     
  3. weschyrchel

    weschyrchel Guest

    0
     
    I got it working

    Hey guys, I think I am on to something here. I am running SuSe9.1 so I don't know if this will apply to everyone, but this is what I did. I started following this guys thread here that had the same problem with the install page, but for Sitebuilder 1.1.1, http://forum.sw-soft.com/showthread.php?s=&threadid=24605&highlight=<IfModule

    The directories have changed in 2.0 so I used,

    /etc/apache2/httpd.conf

    I moved sitebuilder.conf back a directory from vhost.d by doing this, mv sitebuilder.conf .../

    and added the include described in the thread above to the httpd.conf file.

    After doing that I still was receiving the .../install/install.php problems so I received this email from SW-Soft which recommended this move,

    Unfortunatelly this issue persists on SuSe distributives of php.
    Try to add this into the /etc/apache2/vhosts.d/sitebuilder.conf:
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_value open_basedir "/usr/local/sitebuilder:/tmp"
    </IfModule>
    depending on sitebuilder version these lines could be commented out or not by default.

    But the general way to get rid of this is only php recompiling.

    *Issue description*:
    when open sitebuilder url it sometimes have been shown and sometimes not.


    So I added the the code above to sitebuilder.conf after I moved it to /etc/apache2/ and that seems to be working so far. I haven't received the install error since and I found that other applications that I had that were also experiencing the same error due to the Sitebuilder install had to be re-installed. Once that happened it went away.

    Cross your fingers everyone and we'll see if this lasts.
     
  4. weschyrchel

    weschyrchel Guest

    0
     
    Well SiteBuilder worked great for awhile, but then one of my other applications had the same problem. I had to remove the Include related to sitebuilder from the httpd.conf file and then my application started working again.

    I contacted sw-soft and they said to recompile php. They said that would fix my problems. I will do it tonight and see what happens. Hopefully I don't bring my server to it's knees.
     
Loading...