1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SMTP Mail not working after upgrade

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by KirkM, Nov 12, 2010.

  1. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    After upgrading to 10.x, the domain outgoing mail has stopped working. Using the usual mail.domainname.com won't send through 587 or 25. Sending securely through the server's certificate and mailserver on 993 for IMAP accounts is fine.

    Any idea what I can do to fix this?

    Thanks
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Did you tried to investigate Plesk mail log /usr/local/psa/var/log/maillog and rebuild mailsettings with
    /usr/local/psa/admin/sbin/mchk --with-spam
    ?
     
  3. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    I really don't know what I am reading in the maillog, but it doesn't seem to list anything wrong with the site and email address I am using as a test bed. All sites that use the regular domain's mailserver of mail.domain.com for outgoing don't work. Using the server's mailserver works going SSL and using the server's cert. Going non-SSL on port 587 is rejected. POP3 incoming non-ssl on port 110 works. It is only SMTP that isn't working using the domain's mailserver non-ssl. I hope this makes sense.

    I did run the restore:

    [root@secure ~]# /usr/local/psa/admin/sbin/mchk --with-spam
    ==> Checking for: mail_spam_restore... ok
    ==> Checking for: mailsrv_conf_init... ok
    ==> Checking for: mail_mailbox_restore... ok
    ==> Checking for: mailsrv_entities_dump... ok
    ==> Checking for: mail_admin_aliases... ok
    ==> Checking for: mail_auth_dump... ok
    ==> Checking for: mailman_lists_dump... ok
    ==> Checking for: mail_responder_restore... ok
    ==> Checking for: mail_drweb_restore... ok
    ==> Checking for: mail_kav_restore... ok
    ==> Checking for: mail_spf_restore... ok
    ==> Checking for: mail_dk_restore... ok
    ==> Checking for: mail_grey_restore... ok

    It didn't help. My clients using IMAP and going through the main server and its cert are fine. The clients using their domain mailserver can't send mail.

    Thanks for the help.
     
  4. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    Here is an error message one of my clients just sent me:

    Server Error: 530
    Server Response: 530 5.7.0 Must issue a STARTTLS command first
    Server: 'mail.xxxxxx.com'
    Windows Live Mail Error ID: 0x800CCC78
    Protocol: SMTP
    Port: 587
    Secure(SSL): No
     
    Last edited: Nov 13, 2010
  5. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    So now I am making a guess that something is wrong with the authentication in SMTP. Here is a message that all my clients and my test email get when trying to send non-ssl authenticated email out:

    None of the authentication methods supported by this client are supported by your server.

    Using simple password authentication just like before the upgrade only now it is refusing it.
     
  6. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    I have a second test server that is set up identically to my production server. I switched it to Qmail and everything with mail worked fine. I switched it back to postfix and you can't send out regular mail unless you are sending SSL, just like the problem I have on the production server. Clients are pissed. Can't we get some help on this?
     
  7. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    I have had my host provider in contact with Parallels about this issue. Here is Parallels' response:

    =====
    This issue seems to be in a Postfix configuration, because Plesk does not have such kind of settings. I am really sorry to say, but Postfix is a third party-component and Parallels does not support it.

    I am not an expert in Postfix either, though I have found an article for you. Hope it will be useful. It is about adding TLS support to Postfix: http://postfix.state-of-mind.de/patrick.koetter/smtpauth/postfix_tls_support.html

    One more resource containing Postfix How-to-s and FAQs is http://www.postfix.org/docs.html.

    Feel free to ask questions if there is anything else I can do for you.
    =====

    So let me get this straight. Parallels is saying that they don't support software that they include in their Plesk panel, that is an option in the updates section of their Plesk panel and their Plesk panel installs? And by Parallels own admission, it takes an "expert" to configure it. And how come it worked in 9.x and not 10? Plesk has nothing to do with that?
     
    Last edited: Nov 21, 2010
  8. MoRa

    MoRa Guest

    0
     
    /etc/postfix/master.conf

    Scroll down to "submission inet n - n - -......" line.
    Change "smtpd_tls_security_level=encrypt" to "smtpd_tls_security_level=may"

    My first post. Hope it helps.
     
  9. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    Tried it on my test box with both secure IMAP and non-secure POP / SMTP (port 587) and it looks like that works. I am going to hold my breath and put it in on my production server's master.cf in place of the very bad hack I have there now.

    Many thanks for the tip.
     
  10. Knarf

    Knarf Basic Pleskian

    18
    85%
    Joined:
    Jan 22, 2011
    Messages:
    60
    Likes Received:
    0
    Location:
    The Netherlands
    @MoRa,
    I broke my head why my mail with plain text authentication wasn't working anymore on port 587 after the upgrade to Plesk 10. Your solution is working perfectly, so thank you very much!
     
    Last edited: Jan 22, 2011
  11. MoR

    MoR New Pleskian

    15
    55%
    Joined:
    Jun 1, 2010
    Messages:
    2
    Likes Received:
    0
    I am happy to hear its working. Kirk I felt your frustration and it motivated me to figure it out. I just got lucky. You are all very welcome.
     
    Last edited: Jan 23, 2011
  12. fast_eddie

    fast_eddie Guest

    0
     
    Port 587 option not accessible from panel

    Hi - Slightly different scenario as I have upgraded to Plesk 10.0.1 and have QMail server running.

    The Admin Guide says:
    However, the option to configure this isn't available from the Plesk panel!
    Home> Server and Panel Settings> Server-wide mail settings

    Has this functionality been removed or is this a license issue and therefore I can't see it?

    Many thanks
     
  13. PascalF

    PascalF Guest

    0
     
    Same problem after moving from qmail to postfix

    Enabling submission create this line at the very end of master.cf file

    Changing -o smtpd_tls_security_level=encrypt to -o smtpd_tls_security_level=may

    remove the error. Thanks

    BUT. for plesk staff why this error, how to correct it ?

    Also is it normal that I have spamd running with
    Thanks by advance
     
    Last edited by a moderator: Jan 31, 2012
  14. RenatoB

    RenatoB New Pleskian

    13
    35%
    Joined:
    Oct 18, 2011
    Messages:
    14
    Likes Received:
    0
    I think this is quite irresponsability of development, realeasing a update that crash what is working.
    I have a plesk version 11.0.9 on a windows 2008 that was working perfectly for sending emails via smtp.

    All of the sudden after a automatic update the smtp does not work anymore.

    I require urgent help regarding this issue.

    Regards,
    Renato.
     
  15. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  16. RenatoB

    RenatoB New Pleskian

    13
    35%
    Joined:
    Oct 18, 2011
    Messages:
    14
    Likes Received:
    0
    Here it goes IgorG

    ---------------------------------------------------------------
    PRODUCT, VERSION, MICROUPDATE, OPERATING SYSTEM, ARCHITECTURE
    Plesk version 11.0.9 update #34, WINDOWS WEB SERVER 2008 R2, 64 BITS

    PROBLEM DESCRIPTION
    SMTP server stopped working after automatic plesk update, while trying to send email via smtp with password authentication on port 25 the conection attempt times out.

    STEPS TO REPRODUCE
    Configure a client with an account with smtp password authentication on port 25 and it will fail

    ACTUAL RESULT
    All emails does not relay from any account

    EXPECTED RESULT
    All emails to be relayed as it was before after update crash it

    ANY ADDITIONAL INFORMATION
    This is a urgent problem since many customers now are not able to send emails using their accounts.
    A urgent update is necessary to maintain reliability of service.
    --------------------------------------------------------------
     
  17. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Windows? Sorry, but please add any logs, error messages, steps-to-reproduce and any other additional details and move it to Windows section of forum.
    Thanks.
     
Loading...