1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SMTPROUTES - Domain Mail Forwarding

Discussion in 'Plesk for Linux - 8.x and Older' started by zockerjosy, May 6, 2008.

  1. zockerjosy

    zockerjosy Guest

    0
     
    Hello community

    I want to forward all Mails of one domain to an external Mailserver (Exchange). Plesk 8.3 (debian)

    --> Input Kaspersky AntiSPAM -> QMAIL (Plesk) -> forwarding to a different mail server

    There is a configuration file /var/qmail/smtproutes where you could be. How can I do that for a complete domain (* @ mydomain.com)? what is todo?

    Thank You & Greetings,

    Andy
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    You need to first make sure mail is disabled in Plesk for the domain on the server, if it isn't plesk will still try to deliver mail locally. Next make sure the domain is listed in /var/qmail/control/rcpthosts, this configures qmail to accept mail for the domain, and last you create the routes for the domain to the new server in /var/qmail/control/smtproutes. Like this:

    domain.com:10.11.12.13

    Once youve done this, just restart xinetd (/etc/init.d/xinetd restart) and youre done
     
  3. zockerjosy

    zockerjosy Guest

    0
     
    Thank you for your quick response!

    Now I have the problem if an e-mail from outside is received, the server is a relayserver, so the mail is blocked.

    Example:

    ~ $ telnet pleskserver.com 25
    Trying 194.xxx.xx.xx ...
    Connected to pleskserver.com
    Escape character is'^]'.
    220 xyz.pleskserver.com ESMTP
    Helo
    250 pleskserver.com
    mail from: sender@gmx.com
    250 OK
    rcpt to: mike@exchangeserver.com
    553 sorry, that domain is not in my list of allowed rcpthosts (# 5.7.1)

    Greetings,

    Andy
     
  4. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    I really wasnt kidding when I said it needed to be in rcpthosts. :p
     
  5. ecohost

    ecohost Guest

    0
     
    I have the same goal. Thanks for your advice.
    But how do I disable the mail for a given domain?
    Many thanks.
     
  6. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    If you look at the domain settings in plesk, you can turn mail on/off
     
Loading...