1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Spam Assassin Error

Discussion in 'Plesk for Windows - 8.x and Older' started by tinyforks, Apr 10, 2006.

  1. tinyforks

    tinyforks Guest

    0
     
    From the application log:

    System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
    at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
    at System.Net.Sockets.Socket.Send(Byte[] buffer)
    at SpamAssassinService.FilterThread.writeResponse(SpamResult res, String errmsg)
    at SpamAssassinService.FilterThread.threadProc()


    This is on Plesk 7.5.6 running on Windows 2003, ans using Smartermail. Any ideas?
     
  2. Ybuts

    Ybuts Guest

    0
     
    Try to set up the "Number of threads that spam filter can create" parameter as 3 or 4 on the Plesk -> Server -> Spam filter page.
     
  3. tinyforks

    tinyforks Guest

    0
     
    I have it set to three now, but still getting the same error. It looks like it is a conflice from running ClamAV and Spamassassin. I can manufacture the error by running freshclam (Virus updates). I have looked, but can't seem to find a way to check or change either program's port. Any clues?
     
  4. Skeeter

    Skeeter Guest

    0
     
    Hi!

    Does the error persisit when you disable ClamAV?

    Possibly, you should also set the value for the maximum siz of a letter to be spamfiltered (Plesk->Server -> Spamfilter). It should be approx. 400-500Kb.

    Also, it might make sense to decrease the value mentioned by Juri to 2.
     
  5. dynaweb

    dynaweb Guest

    0
     
    Good tip. Worked for me :)
     
Loading...