1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

spamdyke smtpauth

Discussion in 'Plesk for Linux - 8.x and Older' started by nightduke, Nov 18, 2007.

  1. nightduke

    nightduke Guest

    0
     
    Hi i'm trying to use spamdyke with plesk 8.2.1 but smtp auth didn't work and i was unable to send email from my outlook express.
    Gives me an error telling i'm listed on a rbl...

    Anyone knows how can i fix this?

    Thanks

    '554 Refused. Your IP address is listed in the RBL at zen.spamhauss.org See: http://www.spamhaus.org/'
     
  2. mediashaker

    mediashaker Guest

    0
     
    works fine

    I'm using the latest spamdyke with no problems at all plesk 8.2.1. Make sure that you have all your RBLS removed from the default plesk "DNS zones for RBL+ Service" entry in the plesk interface (you don't need it anymore .. as you will be using spamdykes which is much better). You can check this manually by using the commands:

    cat /etc/xinetd.d/smtp_psa
    cat /etc/xinetd.d/smtps_psa

    Make sure that there are no rbls listed and restart xinet.d:

    service xinetd restart

    The great thing about spamdyke is that if you use smtp auth that you can bypass all filters. (where the default rbl's in plesk blocks everything.. usually blocking legit users). Also you can turn on greylisting per domain if you want :)
     
  3. nightduke

    nightduke Guest

    0
     
    Fixed i have compiled spamdyke with no tls.
    Then i have remove from spamdyke.conf the line severcert.

    I restart qmail and xinetd.

    I can send email with autentication enabled with outlook express.

    I will try with Lotus Notes.

    Thanks.

    Nightduke
     
  4. jcalegre

    jcalegre Guest

    0
     
    config files

    Hi,

    could you please post here your spamdyke config file?
    And also your smtp_psa?

    I have the same problem... spamdyke keep blocking my dynamic ip...

    Thanks,

    J. Alegre
     
  5. nightduke

    nightduke Guest

    0
     
    Do you have smtp auth at your smtp?

    Try
    telnet ip address of the server o del servidor

    pones ehlo test
    250-bcserver.midominio.com
    250-AUTH=LOGIN CRAM-MD5 PLAIN
    250-AUTH LOGIN CRAM-MD5 PLAIN
    250-STARTTLS
    250-PIPELINING
    250 8BITMIME


    si te sale auth quiere decir que tienes activado smtp auth a nivel smtp...

    Luego tienes que configurarlo en el spamdyke.

    Espero que te sirva.

    Si necesitas algo mas dimelo.
     
  6. jcalegre

    jcalegre Guest

    0
     
    Continua com problemas.... :\

    Outlook error reported:
    'jorgexxxx@xxxxxxxxxxx.xx' em 04-12-2007 1:05
    554 Dynamic IP Addresses See: http://www.sorbs.net/lookup.shtml?87.196.2.20
    (I´ve checked 'Login before send')


    TELNET:
    220 server.xxxxxxxxxxx.xx ESMTP
    ehlo test
    250-server.xxxxxxxxxxx.xx
    250-AUTH=LOGIN CRAM-MD5 PLAIN
    250-AUTH LOGIN CRAM-MD5 PLAIN
    250-STARTTLS
    250-PIPELINING
    250 8BITMIME

    spamdyke.conf:

    log-level=2
    local-domains-file=/var/qmail/control/rcpthosts
    max-recipients=50
    idle-timeout-secs=60
    graylist-dir=/var/qmail/gray
    graylist-min-secs=300
    graylist-max-secs=1814400
    reject-empty-rdns
    reject-unresolvable-rdns
    reject-ip-in-cc-rdns
    greeting-delay-secs=5
    check-dnsrbl=zombie.dnsbl.sorbs.net
    check-dnsrbl=dul.dnsbl.sorbs.net
    check-dnsrbl=bogons.cymru.com
    smtp-auth-command=/var/qmail/bin/smtp_auth /var/qmail/bin/true
    smtp-auth-command=/var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    local-domains-file=/var/qmail/control/rcpthosts
    reject-missing-sender-mx
    hostname=server.xxxxxxxxxxx.xx
    tls-certificate-file=/var/qmail/control/servercert.pem

    smtp_psa/smtps_psa

    service smtp
    {
    socket_type = stream
    protocol = tcp
    wait = no
    disable = no
    user = root
    instances = UNLIMITED
    server = /var/qmail/bin/tcp-env
    server_args = -Rt0 /var/qmail/bin/relaylock /usr/local/bin/spamdyke -f /etc/spamdyke.conf /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    }


    i've compiled version 3.1.1 using:
    ./configure && make && make install
    and no Errors or warning were reported...

    Do you see anything wrong with my configuration?

    Tx (Obrigado!)

    J.Alegre
     
  7. jcalegre

    jcalegre Guest

    0
     
    Ok, its working now!

    weird :S

    thanks anyway ;)
     
  8. faris

    faris Guest

    0
     
    Wow. I'd not heard of this before. It looks great. I'll give it a try over the weekend.
     
Loading...