1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

ssl certificate problems and geotrust

Discussion in 'Plesk for Linux - 8.x and Older' started by drbasi1, Apr 20, 2005.

  1. drbasi1

    drbasi1 Guest

    0
     
    when trying to upload the private key and certificate for a geotrust ssl certificate, i keep getting permissions errors. please see the attached image for a quick view of the syntax (a bit long for typing).

    in the course of managing my own ssl certificate, i check the default certificate (from plesk) and got permissions errors also. so, basically, i can't see any details on the default or upload my own.

    does anybody know of a fix for such problems?
    please help if you can. thanks in advance.
     
  2. poke

    poke Guest

    0
     
    what the heck are you really asking?? :D

    Please let us know what kind of permission problems you're having. I can't make much sense of this post.

    Are you the admin or a reseller or client on a psa setup? Why perms with ssl?

    regards,
    poke

    I've got dozens of geotrust certs installed on my psa boxes.
     
  3. drbasi1

    drbasi1 Guest

    0
     
    did you see the attached file that i provided? i figured that it would detail the problem better than i have or could word it.

    the basic problem is that i can uccessfully upload the cettificate or private key, but neither takes (as evidenced by an error dialog box that pops up immediately after the upload and set).
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    drbasi1 - if you look at the forum post, you will see that any file you tried to attach is not present (may be restricted on this board).
     
  5. drbasi1

    drbasi1 Guest

    0
     
    sorry for the omitted images. i've provided added detail and an image link below. the thread was also posted here: http://forum.sw-soft.com/showthread.php?threadid=23911

    I cannnot understand why Plesk does not allow me to upload and set the SSL certificate and private key. I was told by Plesk support that it was a permissions error. Per their instructions, I chmoded the appropriate folder and internal files to 666 or 600, but still I get the same result.

    Here's a link to the dialog box and error that I get:
    http://www.basigroup.com/plesk.html

    Thanks in advance for your help. Maybe, I've just been overlooking something very simple.
     
  6. jamesp

    jamesp Guest

    0
     
    I am getting the same errors trying to generate both a CSR and a self-signed cert.

    Please someone help us.
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Have either of you tried:

    chmod 755 /usr/local/psa/admin/conf/

    (there was another post where they used 750 and solved it as well)

    Also make sure the group ownership is psaadm

    Try with 755 first, if it works, then you can back perms down to 750 and see if it still works.

    Remember, search is your friend.
     
Loading...