1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Tomcat configuration and access

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by R.R, Mar 9, 2010.

  1. R.R

    R.R Guest

    0
     
    Hello!
    After updating to Plesk 9.3.0 we have problems with tomcat.
    Two questions:
    a) Is it possible to set "unpackWars=true" in the tomcat-config-file "server.xml" without overwriting it after a stop/start of tomcat?
    b) why is it possible to start the servlet via port 9080 but not via port 8080 (default port of tomcat) or via apache?

    It would be very helpful for us, if somebody knows a solution for it.
    Thank you in advance.
    RR
     
  2. Frank Chang

    Frank Chang Guest

    0
     
    Hello R.R.
    For serious java hosting proxied by Apache on the standard http port (80/443)
    I would recommend you use the solution provided by NGASI. Works with
    Plesk and other CPs. The site http://www.ngasi.com also features a demo.

    FC
     
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  4. R.R

    R.R Guest

    0
     
    Hello,

    thank you for your reply. I have read the documentation - but I do not want to start Tomcat on other ports.
    What I want is that the Tomcat servlet is accessible on port 80 (Apache/Tomcat connector; mod_jk; workers).
    This usually works fine - before and after the Plesk 9.3 update.

    But since the Plesk 9.3 update we have a problem: after the daily cron job at 0:15 am (which stops/starts Apache and Tomcat; we guess it is WatchDog) the servlet is not accessible via port 80 (Apache).
    If this problem occcurs the servlet is still accessible via 9080 - so Tomcat has started correctly.
    We guess that the communication via Apache/Tomcat is not working anymore after the daily cron job.

    What we currently have to do at around 0:20 am is: we deactivate/activate Tomcat and everything is okay.
    But this is no solution: the communication between Apache and Tomcat has to work even after the daily cron job.

    The other question (how to set "unpackWars=true" in the tomcat-config-file "server.xml" without overwriting by Plesk) is still a matter.
    Without setting "unpackWars=true" the installation of a servlets by Plesk hangs - we see the message "please wait" forever.
    Since Plesk must take this parameter from somewhere we would like to know from where - so we can set the correct value.

    Thank you in advance.
    RR
     
Loading...