1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to execute listmng

Discussion in 'Plesk for Linux - 8.x and Older' started by frog3, Apr 27, 2005.

  1. frog3

    frog3 Guest

    0
     
    I receive this error when I'm setting up mailman in the server section of plesk:

    Unable to execute listmng utility: listmng: error: cannot configure Mailman for new domain

    I have been through the forums and first solved the problem that mailman wouldn't start. I did a "newlist mailman" to create a default list.

    But I still have this problem trying to configure mailman. I've done a "check_perms -f" which returns no problems.

    It may help you to know that I am running Fedora Core 3 with psa v7.5.2_build75050128.11 os_FedoraCore 2

    I'm thinking that file locations have moved from FC2 to FC3 and listmng is looking for something that doesn't exist. Thoughts? Thanks!
     
  2. frog3

    frog3 Guest

    0
     
    Any ideas?

    Haven't seen any replies on this one... Anyone have any ideas how to resolve this, or what else I should look for? Are the plans for Plesk on FC3 ?
     
  3. Chris

    Chris Guest

    0
     
    I just had this problem. Make sure your /etc/hosts file is set up correctly.
     
  4. markd

    markd Guest

    0
     
    heh.. spent over two hours on this one, and it turned out to be simple once I figured it out.

    PSA is looking for mailman in /var/mailman/...

    However, if you're running Fedora Core 3, using yum or up2date to install the rpm of Mailman, it defaults to /usr/lib/mailman..

    So.. simply..
    cd /var
    ln -s /usr/lib/mailman mailman

    You're creating a virtual link to the mailman subdirectory in /var/ where Plesk is looking for it.

    If you followed all the steps posted in other threads, i.e. change the fqdn in mm_cfg.py:

    DEFAULT_URL_HOST = fqdn
    DEFAULT_EMAIL_HOST = fqdn

    to your domain:

    DEFAULT_URL_HOST = http://mydomain.com
    DEFAULT_EMAIL_HOST = mydomain.com

    change them back to the fqdn lines. Also in the same file, leave this line

    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)

    intact. If it reads anything other than that, delete it and replace it with above. Do not comment it out!

    If you tried the one work around that told you to create the default mailing list "mailman", delete it using

    /usr/lib//mailman/bin/rmlist mailman

    then stop mailman and restart it..

    /etc/init.d/mailman stop
    /etc/init.d/mailman start

    Go back to Plesk and enter in your default email address and password in the MailMan configuration screen. Viola!

    Basically, Im telling you to start fresh with mailman. Reverse any fixes you might have tried by reading other posts. This will work if you're running Fedora Core 3 and default installed it.


    How'd I find this out? I went to the /usr/local/psa/sbin folder and ran ./listmng by itself. First thing it spit out was:

    [root@ns8 sbin]# ./listmng
    No valid mailman bindir detected

    And the rest was easy to figure out. Now, had I only done that two hours ago, I wouldn't have gotten carpal tunnel.

    :D

    -markd
     
  5. markd

    markd Guest

    0
     
    actually, more on this problem. my above only partially fixed the problem, i.e. Plesk doesn't complain.

    Plesk does create the initial list, and puts the info in the appropriate mailman directories. Where it stops working is when it needs to put the aliases into the /var/qmail/mailnames/<server hostname> and therefore also doesn't place the entry into it's SQL database either.

    So dammit all to hell, just force the Fedora Core 2 RPM of mailman onto your system, and plesk doesn't complain at all and works fine.

    u can get it here:
    ftp://rpmfind.net/linux/fedora/core/updates/2/i386/mailman-2.1.5-10.fc2.i386.rpm

    and use rpm -Uvhf mailman....
    to force it into your system. First, be sure to uninstall the Fedora Core 3 version of MailMan:

    rpm -e mailman

    Ignore any rpm.save warnings. Do that before forcing the FC2 version onto your system.

    -markd
     
Loading...