• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Unable to pipe email to php after upgrading to plesk 12

hessodreamy

New Pleskian
Since upgrading from plesk 11.0.9 to 12.0.18 the other day I have been unable to pipe email content to php.

I know it's not a supported Plesk feature, but when I want email for a particular mailbox to be passed to a php script, I edit the file:
/var/qmail/mailnames/{domain}/{mailbox}/.qmail
and add the line:
| php /some/php/file.php

(I also set the file as immutable to prevent plesk from overwriting it)

However, since upgrading to plesk 12 this no longer works. Furthermore, the mail doesn't get processed and just stays in the local queue, as if the whole file (including instructions on mail directory, and forwarding) is ignored.

I suspect it's a permissions issue, as I can pipe to a shell script just fine, but can't call the desired php command within that shell script.

Although not a supported feature, do any plesk users here have any suggestions to get this behaviour to work? I have functionality that depends on it.
 
Back
Top