1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

unable to upgrade debian etch from 8.6 to 9: serious bugs of xinetd

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by maumar, Dec 12, 2008.

  1. maumar

    maumar New Pleskian

    22
    57%
    Joined:
    Feb 8, 2006
    Messages:
    19
    Likes Received:
    0
    i get this error during upgradeing to plesk 9 by panel:

    Code:
    Reading package lists...
    Building dependency tree...
    Suggested packages:
      sqlite3-doc
    The following packages will be REMOVED:
      psa-courier-imap-add* psa-hotfix3* psa-hotfix4* psa-hotfix5*
    The following NEW packages will be installed:
      libspf2-2 plesk-base psa-hotfix3-9.0.0 psa-mail-driver-common
      psa-mail-qc-driver sqlite3 sw-cp-server sw-engine sw-libboost1.34-filesystem
      sw-libboost1.34-program-options sw-libboost1.34-regex sw-sso xinetd
    The following packages will be upgraded:
      libpam-plesk log4cpp-plesk plesk-billing plesk-skins psa psa-api psa-api-rpc
      psa-awstats-configurator psa-backup-manager psa-ftputil
      psa-locale-base-en-us psa-manual-custom-skin-guide psa-migration-manager
      psa-php5-configurator psa-proftpd psa-proftpd-inetd psa-pylibplesk psa-qmail
      psa-updates psa-watchdog
    20 upgraded, 13 newly installed, 4 to remove and 39 not upgraded.
    Need to get 2648kB/67.1MB of archives.
    After unpacking 3030kB disk space will be freed.
    WARNING: The following packages cannot be authenticated!
      sw-cp-server sw-engine sqlite3 sw-sso sw-libboost1.34-filesystem
      psa-locale-base-en-us psa-api plesk-base psa-php5-configurator plesk-skins
      xinetd psa-qmail libspf2-2 psa-mail-driver-common psa-mail-qc-driver psa
      plesk-billing psa-watchdog psa-backup-manager psa-migration-manager
      psa-pylibplesk libpam-plesk psa-api-rpc psa-updates
      psa-manual-custom-skin-guide log4cpp-plesk sw-libboost1.34-program-options
      sw-libboost1.34-regex psa-ftputil psa-hotfix3-9.0.0 psa-proftpd
      psa-proftpd-inetd psa-awstats-configurator
    Authentication warning overridden.
    Get:1 http://autoinstall.plesk.com etch/all psa-migration-manager 9.0.0-debian4.0.build90081208.07 [2648kB]
    serious bugs of xinetd ( -> 1:2.3.14-1) <done>
     #427892 - circumvents invoke-rc.d (and thus policy-rc.d) in postinst (Fixed: xinetd/1:2.3.14-1.1)
    Summary:
     xinetd(1 bug)
    
    ****************************************************************************
    ****** Exit with an error by force in order to stop the installation. ******
    ****************************************************************************
    E: Sub-process if dpkg -s apt-listbugs | grep -q '^Status: .* ok installed'; then /usr/sbin/apt-listbugs apt || ( test $? -ne 10 || exit 10; echo 'Warning: apt-listbugs exited abno
    rmally, hit enter key to continue.' 1>&2 ; read a < /dev/tty ); fi returned an error code (10)
    E: Failure running script if dpkg -s apt-listbugs | grep -q '^Status: .* ok installed'; then /usr/sbin/apt-listbugs apt || ( test $? -ne 10 || exit 10; echo 'Warning: apt-listbugs
    exited abnormally, hit enter key to continue.' 1>&2 ; read a < /dev/tty ); fi
    Fetched 2648kB in 2s (1225kB/s)
    -- Check for new version of PSA_9.0.0/plesk-9.0.0-deb4.0-i386.inf3
    Filefetcher: get file (~empty)/PSA_9.0.0/plesk-9.0.0-deb4.0-i386.inf3
    Execute command apt-get update
    Get:1 http://debian.fastweb.it etch Release.gpg [386B]
    Hit http://debian.fastweb.it etch Release
    Ign http://debian.fastweb.it etch/main Packages/DiffIndex
    Ign http://debian.fastweb.it etch/contrib Packages/DiffIndex
    Ign http://debian.fastweb.it etch/non-free Packages/DiffIndex
    Ign http://debian.fastweb.it etch/main Sources/DiffIndex
    Hit http://debian.fastweb.it etch/main Packages
    Hit http://debian.fastweb.it etch/contrib Packages
    Hit http://debian.fastweb.it etch/non-free Packages
    Hit http://debian.fastweb.it etch/main Sources
    Get:2 http://security.debian.org etch/updates Release.gpg [189B]
    Hit http://security.debian.org etch/updates Release
    Ign http://security.debian.org etch/updates/main Packages/DiffIndex
    Hit http://security.debian.org etch/updates/main Packages
    Fetched 2B in 0s (13B/s)
    Reading package lists...
    ERROR: An error occurred on attempt to install packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    
    
    upgrade is stopped and system is unchanged (luckily)
     
Loading...