Dismiss Notice
Plesk Onyx 17.5 is now available for everyone and we'd love to hear your thoughts on the new Plesk version. Visit this thread for more details.

Question Undelivered Mail Returned to Sender

Discussion in 'Plesk 12.x for Linux' started by yabado, Feb 15, 2017.

Tags:
  1. yabado

    yabado Regular Pleskian

    16
    85%
    Messages:
    189
    Likes Received:
    3
    Trophy Points:
    237
    My server is getting hammered with spam and for some reason the server still sends bounce messages with subject "Undelivered Mail Returned to Sender" even though everything is set to Reject.

    Why is it still sending these emails. Causes tons of backscatter.

    Running Linux , Cloudlinux and 12.5.x
     
  2. Peter Debik

    Peter Debik Golden Pleskian Plesk Guru

    32
    80%
    Messages:
    1,133
    Likes Received:
    144
    Trophy Points:
    712
    Location:
    Berlin, Germany
    Where exactly have you set "everything to Reject"? The only place I'd know of is the catch-all control for undefined mail addresses. "Reject" in that case does not mean "silently swallow", but return a REJECT information to the sender. If you do not want to receive mail on a specific domain at all, you can uncheck "Activate mail service on this domain" on the catch-all control page.
     
  3. yabado

    yabado Regular Pleskian

    16
    85%
    Messages:
    189
    Likes Received:
    3
    Trophy Points:
    237
    I have it set on each domains Mail Settings for the "What to do with mail for non-existent users" option. The options are Bounce, Forward and Reject.
    Are you saying that Reject STILL sends a bounce message?

    I just want a way to have ALL mail sent to non-existent users ( entire server, all domains ) just goes away, no email response, just dies.

    Is there a way to do this?
     
  4. Peter Debik

    Peter Debik Golden Pleskian Plesk Guru

    32
    80%
    Messages:
    1,133
    Likes Received:
    144
    Trophy Points:
    712
    Location:
    Berlin, Germany
    The normal solution to do that is to send all incoming mails to /dev/null or to deny incoming mail service in general. As the first does not work on Plesk, because Plesk complains about invalid mail format if you try to forward mail to /dev/null, I suggest to deactivate mail service by unchecking "Activate mail service on this domain".
     
  5. yabado

    yabado Regular Pleskian

    16
    85%
    Messages:
    189
    Likes Received:
    3
    Trophy Points:
    237
    Thanks for taking time to reply, but that is not a realistic option. If anyone else has a way to prevent this from happening please chime in.

    There has to be a direct postfix config I can add to get this done.
     
  6. yabado

    yabado Regular Pleskian

    16
    85%
    Messages:
    189
    Likes Received:
    3
    Trophy Points:
    237
  7. Peter Debik

    Peter Debik Golden Pleskian Plesk Guru

    32
    80%
    Messages:
    1,133
    Likes Received:
    144
    Trophy Points:
    712
    Location:
    Berlin, Germany
Loading...