1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Updating Apache

Discussion in 'Plesk for Linux - 8.x and Older' started by JeriR, Jun 27, 2006.

  1. JeriR

    JeriR Guest

    0
     
    HI,

    I'm new to Plesk, so I hope this question doesn't sound too foolish.

    It's my understanding that Plesk uses a special version of Apache, correct?

    I'm using

    Version psa v8.0.1_build80060618.11 os_FedoraCore 4
    OS Linux 2.6.16-1.2115_FC4

    According the Component Info :

    httpd 2.0.54-10.3

    ====

    Now here's the problem.

    With this version of Apache, and version 2.0.55 if you use multiple includes you get segmentation errors.

    http://bugs.php.net/bug.php?id=35484

    On a simple page, we have the header, navbar and footers as includes. Then we have 1 or more MySQL query results on the page.

    The MySQL works fine by itself, but add an include and it stops working.

    ===

    So, my question is how do I get Apache 2.0.56 or greater on the server?

    Is this updated automatically by the updater? If it is, based on past experience any idea how long it would be?

    Right now I have over 100 broken sites because of this.

    Thanks,

    Jer
     
  2. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Plesk does not use a 'special' version of apache, it uses the version distributed by the OS you run Plesk on.
     
  3. JeriR

    JeriR Guest

    0
     
  4. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    The bug report you're linking to says the bug was fixed in CVS in december 2005. I'd think that that fix would be present in current PHP packages then. The report also says the bug was fixed in PHP, not in Apache, so I wouldn't look into upgrading Apache.

    Also make sure you understand Red Hat's backporting practices, before you start looking at version numbers to see if a package has a (security) fix: http://www.redhat.com/advice/speaks_backport.html.
     
  5. JeriR

    JeriR Guest

    0
     
    Well my PHP version is Version 5.0.4, which came out 31-Mar-2005.
    My Apache is 2.0.54-10.3.

    It was fixed in PHP in December 2005. So the PHP version is the "broken"
    version.

    This is a server that was just configured last Friday. The Plesk Base
    Packages are all up to date.

    Time to ask if the admins if they can update PHP.

    Thanks,

    Jer
     
  6. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    If you would have read the backporting article I sent you you can see you're not necessarily right, as Red Hat will have probably released a lot of different 5.0.4 packages.

    But looking at http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/, I see that the latest updated PHP 5.0.4 packages for FC4 (php-5.0.4-10.5) were released on 8 November 2005. So, that might indicate the packages won't have the fix.

    Next stop: Bugzilla. Searching for "virtual include php" I found this open bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=187253

    It doesn't seem to be filed against FC4 though. You might want to add that the error exists on FC4 as well.

    There are PHP 5.0.5 packages in updates-testing though (released 8 May 2006), you could try those to see if they fix your problem. According to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=183948 the 5.0.5-2.1 packages had a problem with crashing using squirrelmail. The current packages in updates-testing are 5.0.5-2.2 however, so they might have that fixed as well.
     
Loading...